关于 省赛模拟赛(迪迦桑专场)

      这一次的小比赛,因为全是英文题,导致了我们队的心态有点崩,以前很少打这种全是英文的比赛, 但是我们明知道以后还会打这种比赛, 却没有提前做好准备。 

  这一次的比赛我们全程跟着榜单走, 我们队一开始采取了2+1的打法, 让一个人去钻一道题, 其他两个人去快速的解决一些简单的题, 然后在解决两道题之后, 变为了一人钻一题的模式, 但是依旧没有太大的突破。

这一次我写的是C题,因为一个小漏洞,导致了一直WA,最后还是没有找出来。。。。以后多去找一些细节问题,做到下次不会再栽在这个问题上面。

Japari Park is a large zoo home to extant species, endangered species, extinct species, cryptids and some legendary creatures. Due to a mysterious substance known as Sandstar, all the animals have become anthropomorphized into girls known as Friends.

Kaban is a young girl who finds herself in Japari Park with no memory of who she was or where she came from. Shy yet resourceful, she travels through Japari Park along with Serval to find out her identity while encountering more Friends along the way, and eventually discovers that she is a human.

However, Kaban soon finds that it's also important to identify other Friends. Her friend, Serval, enlightens Kaban that she can use some questions whose expected answers are either "yes" or "no" to identitfy a kind of Friends.

To be more specific, there are n Friends need to be identified. Kaban will ask each of them q same questions and collect their answers. For each question, she also gets a full list of animals' names that will give a "yes" answer to that question (and those animals who are not in the list will give a "no" answer to that question), so it's possible to determine the name of a Friends by combining the answers and the lists together.

But the work is too heavy for Kaban. Can you help her to finish it?

Input

There are multiple test cases. The first line of the input is an integer T (1 ≤ T ≤ 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains two integers n (1 ≤ n ≤ 100) and q (1 ≤ q ≤ 21), indicating the number of Friends need to be identified and the number of questions.

The next line contains an integer c (1 ≤ c ≤ 200) followed by c strings p1p2, ... , pc (1 ≤ |pi| ≤ 20), indicating all known names of Friends.

For the next q lines, the i-th line contains an integer mi (0 ≤ mi ≤ c) followed by mi strings si, 1si, 2, ... , simi (1 ≤ |sij| ≤ 20), indicating the number of Friends and their names, who will give a "yes" answer to the i-th question. It's guaranteed that all the names appear in the known names of Friends.

For the following n lines, the i-th line contains q integers ai, 1ai, 2, ... , aiq (0 ≤ aij ≤ 1), indicating the answer (0 means "no", and 1 means "yes") to the j-th question given by the i-th Friends need to be identified.

It's guaranteed that all the names in the input consist of only uppercase and lowercase English letters.

Output

For each test case output n lines. If Kaban can determine the name of the i-th Friends need to be identified, print the name on the i-th line. Otherwise, print "Let's go to the library!!" (without quotes) on the i-th line instead.

Sample Input
2
3 4
5 Serval Raccoon Fennec Alpaca Moose
4 Serval Raccoon Alpaca Moose
1 Serval
1 Fennec
1 Serval
1 1 0 1
0 0 0 0
1 0 0 0
5 5
11 A B C D E F G H I J K
3 A B K
4 A B D E
5 A B K D E
10 A B K D E F G H I J
4 B D E K
0 0 1 1 1
1 0 1 0 1
1 1 1 1 1
0 0 1 0 1
1 0 1 1 1
Sample Output
Serval
Let's go to the library!!
Let's go to the library!!
Let's go to the library!!
Let's go to the library!!
B
Let's go to the library!!
K


#include <stdio.h>
#include <string.h>
#define N 250

int main()
{
    int T, n, m, k, i, j, q, x;
    char a[N][N], ch[N];
    int b[N][N];
    scanf("%d", &T);
    while(T--)
    {
        memset(b,0,sizeof(b));
        scanf("%d%d",&n,&m);
        scanf("%d",&k);
        for (i=0; i<k; i++)
        {
            scanf("%s",a[i]);
        }
        for (i=0; i<m; i++)
        {
            scanf("%d",&x);
            for (j=0; j<x; j++)
            {
                scanf("%s", ch);
                for (q=0; q<k; q++)
                {
                    if (strcmp(ch, a[q])==0)
                    {
                        b[i][q]=1;
                        break;
                    }
                }
            }
        }
        int vi[N];
        int f, qq;
        for (i=0; i<n; i++)
        {
            for (j=0; j<m; j++)
            {
                scanf("%d",&vi[j]);
            }
            int sum=0;
            for (j=0; j<k; j++)///就是这里的k一不小心敲成了x导致了一直WA;
            {
                f=1;
                for (q=0; q<m; q++)
                {
                    if (vi[q]!=b[q][j])
                    {
                        f=0;
                        break;
                    }
                }
                if (f==1)
                {
                    sum++;
                    qq=j;
                }
            }
            if(sum==1)
                printf("%s\n",a[qq]);
            else
                printf("Let's go to the library!!\n");
        }
    }
    return 0;
}

 

posted on 2017-04-28 09:35  小春天  阅读(312)  评论(0编辑  收藏  举报

导航