poj3041 Asteroids

Asteroids
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 24203   Accepted: 13112

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

题目大意:每一次可以将一行或一列的X全部变成O,问最少多少次能够使所有的X变成O.
分析:二分图匹配挺容易想到的吧.比较容易想到的想法就是对于点(x,y),x向y连一条有向边,接着思路就很容易地出来了.
#include <cstdio>
#include <queue>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int n,k,a[510][1010],flag[1010],pipei[1010],ans;

bool dfs(int u)
{
    for (int i = n + 1; i <= n * 2; i++)
    {
        if (!flag[i] &&a[u][i])
        {
            flag[i] = 1;
            if (!pipei[i] || dfs(pipei[i]))
            {
                pipei[i] = u;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    scanf("%d%d",&n,&k);
    for (int i = 1; i <= k; i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        a[x][y + n] = 1;
    }
    for (int i = 1; i <= n; i++)
    {
        memset(flag,0,sizeof(flag));
        if(dfs(i))
            ans++;
    }
    printf("%d\n",ans);

    return 0;
}

 

posted @ 2017-12-27 18:16  zbtrs  阅读(126)  评论(0编辑  收藏  举报