poj3461 Oulipo

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 44519   Accepted: 17845

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

分析:KMP模板题.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int T, len1, len2, ans, nextt[1000010];
char s1[1000010], s2[1000010];

void init()
{
    int j = 0;
    for (int i = 2; i <= len1; i++)
    {
        while (j > 0 && s1[j + 1] != s1[i])
            j = nextt[j];
        if (s1[j + 1] == s1[i])
            j++;
        nextt[i] = j;
    }
}

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        memset(nextt, 0, sizeof(nextt));
        ans = 0;
        scanf("%s", s1 + 1);
        scanf("%s", s2 + 1);
        len1 = strlen(s1 + 1);
        len2 = strlen(s2 + 1);
        init();
        int j = 0;
        for (int i = 1; i <= len2; i++)
        {
            while (j > 0 && s1[j + 1] != s2[i])
                j = nextt[j];
            if (s1[j + 1] == s2[i])
                j++;
            if (j == len1)
                ans++;
        }
        printf("%d\n", ans);
    }

    return 0;
}

 

posted @ 2017-12-16 10:54  zbtrs  阅读(151)  评论(0编辑  收藏  举报