hdu 2132... 被基本问题考住了。。
Problem Description
We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
We can define sum(n) as follow:
if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
Is it very easy ? Please begin to program to AC it..-_-
Now there is a very easy problem . I think you can AC it.
We can define sum(n) as follow:
if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
Is it very easy ? Please begin to program to AC it..-_-
Input
The input file contains multilple cases.
Every cases contain only ont line, every line contains a integer n (n<=100000).
when n is a negative indicate the end of file.
Every cases contain only ont line, every line contains a integer n (n<=100000).
when n is a negative indicate the end of file.
Output
output the result sum(n).
Sample Input
1
2
3
-1
Sample Output
1
3
30
#include<iostream>
using namespace std;
int main()
{
__int64 i,n,a[100001];
a[0]=0;
for(i=1;i!=100001;++i)
{
if(i%3==0)
a[i]=a[i-1]+i*i*i;////// i*i*i的过程中 当I等于99999的时候 用int去存的话 有溢出(这里是吧i*i*i的值放在一个int的空间里面 然后再进行赋值运算 要尤其注意)
else
a[i]=a[i-1]+i;
}
while(cin>>n&&n>=0)
{
cout<<a[n]<<endl;
}
return 0;
}