NOIP信息学 1039:判断数正负--信息学一本通(c++)

时间限制: 1000 ms 内存限制: 65536 KB
提交数: 34909 通过数: 17501
【题目描述】
给定一个整数N,判断其正负。如果N>0,输出positive;如果N=0,输出zero;如果N<0,输出negative。

【输入】
一个整数N(−109≤N≤109)。

【输出】
如果N>0, 输出positive;

如果N=0, 输出zero;

如果N<0, 输出negative。

【输入样例】
1
【输出样例】
positive
【来源】

No

代码如下:
#include <iostream>
#include <iomanip>
#include <cmath>
using namespace std;
int main()
{
    int N;
    cin >> N;
    if (N > 0) cout << "positive" << endl;
    else if (N == 0) cout << "zero" << endl;
    else cout << "negative" << endl;
    return 0;
}

全套noip信息学资料

链接:https://pan.baidu.com/s/1V_SsiWMY8I_HKI-WjFfNcw 
提取码:40hf 

posted @ 2020-04-07 12:45  tianli3151  阅读(1083)  评论(0编辑  收藏  举报