Who's in the Middle
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 31449   Accepted: 18269

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output

* Line 1: A single integer that is the median milk output.

Sample Input

5
2
4
1
3
5

Sample Output

3

Hint

INPUT DETAILS: 

Five cows with milk outputs of 1..5 

OUTPUT DETAILS: 

1 and 2 are below 3; 4 and 5 are above 3.

Source

參考算法导论9.2。以期望线性时间做选择
AC代码:
#include<iostream>
using namespace std;
int a[10010];
int partition(int *a,int p,int r){
    int x=a[r];
    int i=p-1;
    for(int j=p;j<=r-1;j++){
        if(a[j]<x){
            i++;
            int tmp=a[i];
            a[i]=a[j];
            a[j]=tmp;
        }
    }
    int tmp=a[i+1];
    a[i+1]=a[r];
    a[r]=tmp;
    return i+1;
}
int R_Select(int *a,int p,int r,int i){
    if(p==r)
        return a[p];
    int q=partition(a,p,r);
    int k=q-p+1;
    if(i==k)
        return a[q];
    else if(i<k)
        return R_Select(a,p,q-1,i);
    else
        return R_Select(a,q+1,r,i-k);
}
int main(){
    int n;
    while(cin>>n){
        for(int i=1;i<=n;i++){
            cin>>a[i];
        }
        cout<<R_Select(a,1,n,n/2+1)<<endl;
    }
    return 0;
}


posted on 2017-07-16 15:51  yutingliuyl  阅读(210)  评论(0编辑  收藏  举报