Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1237    Accepted Submission(s): 408


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input
2 1 0 1 10 4 0
 

Sample Output
10 impossible
 

Author
Wiskey
浮在水面上的小岛要连通,求最少花费,假设没有,则输出impossible。
代码1【克鲁斯卡尔】:


#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<cmath>
using namespace std;

int n,m;
int pre[1010];
struct node{
       int u;
       int v;
       int w;
};
node sb[10010];

bool cmp(node a,node b)
{
     return a.w<b.w;
}

int find(int x)
{
    if(pre[x]==x)
    return x;
    return pre[x]=find(pre[x]);
    }

bool join(int x,int y)
{
     int f1,f2;
     f1=find(x);
     f2=find(y);
     if(f1==f2)
     return false;
     if(f1!=f2)
     pre[f1]=f2;
     return true;
}

int main()
{
    int sum;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
           sum=0;
          for(int i=0;i<n;i++)
          pre[i]=i;
          for(int i=0;i<m;i++)
          scanf("%d%d%d",&sb[i].u,&sb[i].v,&sb[i].w);
          sort(sb,sb+m,cmp);
          for(int i=0;i<m;i++)
          {
             if(join(sb[i].u,sb[i].v))
             sum+=sb[i].w;
          }
          int cnt=0;
          for(int i=0;i<n;i++)
          {
                  if(pre[i]==i)
                cnt++;
          }
          if(cnt>1)
          printf("impossible\n\n");
          else
          printf("%d\n\n",sum);
    }
    return 0;
}

代码2【普利姆】:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
const int  INF= 0x3f3f3f3f;
const int maxb=1010;
int  map[maxb][maxb];
int vis[maxb];
int n,m,sum;
int a,b,c;

void prime()
{
    int i,j,k,dis[maxb];
    int min;
    memset(vis,0,sizeof(vis));
    int ans=1;
    vis[0]=1;
    for(i=0;i<n;i++)
        dis[i]=map[0][i];
    for(i=0;i<n;i++)
    {
        min=INF;
        for(j=0;j<n;j++)
            if(!vis[j]&&min>dis[j])
            min=dis[k=j];
        if(min==INF)
        {
            if(ans==n)
            printf("%d\n",sum);
            else
            puts("impossible");
            break;
        }
        sum+=min;
        vis[k]=1;
        ans++;
        for(j=0;j<n;j++)
        if(!vis[j]&&dis[j]>map[k][j])
        dis[j]=map[k][j];
    }
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(map,INF,sizeof(map));
        sum=0;
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(map[a][b]>c)
            map[a][b]=map[b][a]=c;
        }
        //getchar(); 
        prime();
        //getchar(); 
        puts("");
    }
    return 0;
}





posted on 2017-06-09 09:58  yutingliuyl  阅读(160)  评论(0编辑  收藏  举报