第十二周作业
第十二周作业
| 这个作业属于哪个课程 | C语言程序设计ll |
| -------- | -----: | :----: |
| 这个作业要求在哪里 | (https://edu.cnblogs.com/campus/zswxy/software-engineering-class2-2018/homework/3234)|
| 我在这个课程的目标是 | 能够掌握二级指针的概念,以及指针数组的应用;了解指针与函数的关系,掌握指针作为函数返回值; |
| 这个作业在哪个具体方面帮助我实现目标 | 了解了指针函数和函数指针的区别 |
|参考文献|(https://blog.csdn.net/u012741741/article/details/66478883)|
一、基础题
1、 计算最长的字符串长度 (15 分)
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:
int max_len( char *s[], int n );
其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。
裁判测试程序样例:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 10
#define MAXS 20
int max_len( char *s[], int n );
int main()
{
int i, n;
char *string[MAXN] = {NULL};
scanf("%d", &n);
for(i = 0; i < n; i++)
{
string[i] = (char *)malloc(sizeof(char)*MAXS);
scanf("%s", string[i]);
}
printf("%d\n", max_len(string, n));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
4
blue
yellow
red
green
输出样例:
6
(1)实验代码
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 10
#define MAXS 20
int max_len( char *s[], int n );
int main()
{
int i, n;
char *string[MAXN] = {NULL};
scanf("%d", &n);
for(i = 0; i < n; i++)
{
string[i] = (char *)malloc(sizeof(char)*MAXS);
scanf("%s", string[i]);
}
printf("%d\n", max_len(string, n));
return 0;
}
int max_len(char *s[],int n)
{
int i,max=0;
for(i=0;i<n;i++)
{
int len = strlen(s[i]);
if(len>max)
{
max=len;
}
}
return max;
}
(3)本题调试过程中碰到问题及解决方法
无
(4)运行结果截图
2、统计专业人数 (15 分)
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:
struct ListNode {
char code[8];
struct ListNode *next;
};
这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。
函数接口定义:
int countcs( struct ListNode *head );
其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct ListNode {
char code[8];
struct ListNode *next;
};
struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );
int main()
{
struct ListNode *head;
head = createlist();
printf("%d\n", countcs(head));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1021202
2022310
8102134
1030912
3110203
4021205
#
输出样例:
3
(1)实验代码
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct ListNode {
char code[8];
struct ListNode *next;
};
struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );
int main()
{
struct ListNode *head;
head = createlist();
printf("%d\n", countcs(head));
return 0;
}
int countcs(struct ListNode *head)
{
int sum=0;
while(head) //用计数器记录字符串第二三个是否为02就可以了
{
if(head -> code[1] == '0' && head -> code[2] == '2') //指向运算符->
{
sum++;
}
head = head -> next;
}
return sum;
}
(3)本题调试过程中碰到问题及解决方法
无
(4)运行结果截图
3、删除单链表偶数节点 (20 分)
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
函数接口定义:
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}
int main()
{
struct ListNode *head;
head = createlist();
head = deleteeven(head);
printlist(head);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 2 2 3 4 5 6 7 -1
输出样例:
1 3 5 7
(1)实验代码
typedef struct ListNode *List;
struct ListNode *createlist()
{
List head=NULL, tail=NULL;
int k;
scanf("%d",&k);
while(k!=-1)
{
List temp = (List)malloc(sizeof(struct ListNode));
temp->data = k;
temp->next = NULL;
if(tail==NULL)
{
head = tail = temp;
}
else
{
tail->next = temp;
tail = temp;
}
scanf("%d",&k);
}
return head;
}
struct ListNode *deleteeven( struct ListNode *head )
{
List s=head,q;
while(head&&head->data%2==0)
{
s=head;
head=head->next;
free(s);
}
s=head;
while(s&&s->next)
{
while(s->next&&s->next->data%2==0)
{
q=s->next;
s->next=q->next;
}
s=s->next;
}
return head;
}
(3)本题调试过程中碰到问题及解决方法
这道题不会做,具体运用哪种语句不是很清楚,后来看了其他博主的才懂
(4)运行结果截图
二、学习感悟
唯有独立思考才有进步的空间,继续加油
结对编程感受
还是从课本入手,兴趣是最好的老师,交流更能解决问题
学习进度表
周/日期 | 这周所花的时间 | 代码行数 | 学到的知识点简介 | 目前比较迷惑的问题 |
---|---|---|---|---|
2/25-3/3 | 三天 | 45 | 数组的认识及用法 | 数组长度的理解 |
3/4-3/10 | 两天 | 37 | 编写程序时处理文件 | fscanf与fprintf的具体用法 |
3/11-3/17 | 三天 | 53 | 二维数组的使用及文件插入 | 二维数组的用法、上三角的判断及文件的处理 |
3/18-3/24 | 两天 | 113 | 选择排序法、二分查找法、二维数组的引用与矩阵 | 不清楚选择排序法和冒泡排序法的区别 |
3/25-3/31 | 两天 | 78 | 判断回文、一维字符数组的用法、使用字符串编程 | 使用字符串编程 |
4/1-4/7 | 两天 | 88 | 指针变量的基本运算,内存单元和地址之间的关系 | 不太了解指针数组 |
4/8-4/14 | 两天 | 96 | 指针、数组和地址之间的关系 | 对于指针数组和数组指针的区别不是特别清楚 |
4/15-4/21 | 两天 | 128 | 字符串和字符指针、常用的字符串处理函数 及用指针实现内存动态分配 | 对于指针都不是特别懂 |
4/22-4/28 | 两天 | 120 | 定义结构,使用结构变量与结构数组进行编程 | 结构体参与判断 |
4/29-5/4 | 一天 | 0 | 结构数组及结构指针 | 结构指针 |
5/5-5/11 | 两天 | 26 | 递归函数的定义及使用 | 递归函数的使用 |
5/12-5/18 | 两天 | 153 | 指针函数与函数指针的区别 | 不太会用二级指针 |
六、表格和折线图
时间 | 代码行数 | 博客字数 |
---|---|---|
第一周 | 45 | 852 |
第二周 | 37 | 1236 |
第三周 | 112 | |
第四周 | 113 | |
第五周 | 78 | 1900 |
第六周 | 114 | |
第七周 | 96 | 3200 |
第八周 | 128 | 3300 |
第九周 | 120 | 3423 |
第十周 | 0 | 3216 |
第十一周 | 262 | 3186 |
第十二周 | 153 | 3045 |