P2858 [USACO06FEB]Treats for the Cows G/S 题解

[USACO06FEB]Treats for the Cows G/S

[USACO06FEB]Treats for the Cows G/S

题目描述

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.Like fine wines and delicious cheeses, the treats improve with age and command greater prices.The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

约翰经常给产奶量高的奶牛发特殊津贴,于是很快奶牛们拥有了大笔不知该怎么花的钱.为此,约翰购置了N(1≤N≤2000)份美味的零食来卖给奶牛们.每天约翰售出一份零食.当然约翰希望这些零食全部售出后能得到最大的收益.这些零食有以下这些有趣的特性:

•零食按照1..N编号,它们被排成一列放在一个很长的盒子里.盒子的两端都有开口,约翰每

天可以从盒子的任一端取出最外面的一个.

•与美酒与好吃的奶酪相似,这些零食储存得越久就越好吃.当然,这样约翰就可以把它们卖出更高的价钱.

•每份零食的初始价值不一定相同.约翰进货时,第i份零食的初始价值为Vi(1≤Vi≤1000).

•第i份零食如果在被买进后的第a天出售,则它的售价是vi×a.

Vi的是从盒子顶端往下的第i份零食的初始价值.约翰告诉了你所有零食的初始价值,并希望你能帮他计算一下,在这些零食全被卖出后,他最多能得到多少钱.

输入格式

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)

输出格式

Line 1: The maximum revenue FJ can achieve by selling the treats

样例 #1

样例输入 #1

5
1
3
1
5
2

样例输出 #1

43

提示

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.


先解释一下这个题目没有翻译的部分

输入格式

Line 1: A single integer, N
翻译:第1行:单个整数,N
Lines 2..N+1: Line i+1 contains the value of treat v(i)
翻译:第2行:N+1行:第i+1行包含处理v(i)的值

输出格式

Line 1: The maximum revenue FJ can achieve by selling the treats
翻译:1行:FJ的最大收入

提示

Explanation of the sample:
Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).
FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

翻译:五个方式。在第一天,FJ可以出售第1号(价值1)或第5号治疗(值2)。FJ按指数的以下顺序销售零食(值1、3、1、5、2):1、5,2、3、4,使1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43。

这又是一道普通的dp算法题目,直接上状态转移方程:

dp[j][ans]=max(dp[j][ans1]+vis[ans](numi+1),dp[j+1][ans]+vis[j](numi+1))

#include<bits/stdc++.h>
#define N 2010
using namespace std;
int num=0,dp[N][N]={},vis[N]={};
int main(){
	/*开始输入*/
    cin>>num;
    for(int i=1;i<=num;i++){
    	cin>>vis[i];
	}
    for(int i=1;i<=num;i++){
    	dp[i][i]=vis[i]*num;//第i份零食能获得的最大价值就是把它留到第num天卖 
	}
	/*输入结束*/
    for(int i=2;i<=num;i++){
        for(int j=1;j<=num;j++){
            int ans=j+i-1;
            if(ans>num){
            	break;
			}
            dp[j][ans]=max(dp[j][ans-1]+vis[ans]*(num-i+1),dp[j+1][ans]+vis[j]*(num-i+1));//状态转移方程
        }
    }
    cout<<dp[1][num];//输出1~num
    return 0;//好习惯
}
posted @   yuan_qwq  阅读(50)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· ollama系列01:轻松3步本地部署deepseek,普通电脑可用
· 25岁的心里话
· 按钮权限的设计及实现
点击右上角即可分享
微信分享提示