SDUT 1048 Digital Roots

Digital Roots

Time Limit: 1000ms   Memory limit: 65536K 

题目描述

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
 
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

输入

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

输出

For each integer in the input, output its digital root on a separate line of the output.

示例输入

24
39
0

示例输出

6
3

提示

请注意,输入数据长度不超过20位数字。
      题目要求:给你一串数字,这些数字的“和”,如果大于一位数,则再将他们的和数字的每一位再相加,如此下去,直到数字和为一位数字!
     算法思想很简单,多用了几个while循环,关键是思路要清晰!
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#include <stdio.h>
#include <string.h>
 
int main()
{
    char s[50];
    int a[50], e;
    int i, j, k;
    int sum;
    while(scanf("%s", s)!=EOF )
    {
        if(s[0]=='0')
        break;
        int len=strlen(s);
        e=0;
        sum=0;
        for(i=0; i<len; i++)
        {
            a[e++]=s[i]-48 ;
            sum+=a[e-1];
        }
        if(sum<10)
            printf("%d\n", sum );
        else
        {
            int cnt=sum;
            sum=0;
            while(cnt>10)
            {
                while(cnt!=0)
                {
                    sum=sum + (cnt%10);
                    cnt=cnt/10;
                }
                if(sum<10)
                {
                    printf("%d\n", sum );
                    break;
                }
                else
                {
                    cnt=sum;
                    sum=0;
                }
            }
        }
    }
    return 0;
}

 

posted @   我喜欢旅行  阅读(177)  评论(0编辑  收藏  举报
编辑推荐:
· 智能桌面机器人:用.NET IoT库控制舵机并多方法播放表情
· Linux glibc自带哈希表的用例及性能测试
· 深入理解 Mybatis 分库分表执行原理
· 如何打造一个高并发系统?
· .NET Core GC压缩(compact_phase)底层原理浅谈
阅读排行:
· DeepSeek火爆全网,官网宕机?本地部署一个随便玩「LLM探索」
· 开发者新选择:用DeepSeek实现Cursor级智能编程的免费方案
· 【译】.NET 升级助手现在支持升级到集中式包管理
· 独立开发经验谈:如何通过 Docker 让潜在客户快速体验你的系统
· Tinyfox 发生重大改版
点击右上角即可分享
微信分享提示