POJ 之 1002 :487-3279

487-3279
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 242418   Accepted: 42978

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

使用STL map做的,开的内存很大,不过这样写比较简单,清楚明了!
Accepted的代码 :
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
#include <stdio.h>
#include <string.h>
#include <string>
#include <map>
#include <algorithm>
 
using namespace std;
 
int main()
{
    int t;
    map<string, int>ma;
    map<string, int>::iterator it;
    char s[1000];
    char ch[30];
    int i, len;
    int sum;
    while(scanf("%d", &t)!=EOF)
    {
        ma.clear();
        sum=0;
        while(t--)
        {
            scanf("%s", s);
             len=strlen(s);
            int e=0;
            for(i=0; i<len; i++)
            {
                if(s[i]>='0' && s[i]<='9' )
                {
                    ch[e++]=s[i];
                    if(e==3)
                    {
                        ch[e++]='-';
                    }
                }
                else if(s[i]>='A' && s[i]<='C' )
                {
                    ch[e++]='2';
                    if(e==3)
                    {
                        ch[e++]='-';
                    }
                }
                else if(s[i]>='D' && s[i]<='F' )
                {
                    ch[e++]= '3' ;
                    if(e==3)
                    {
                        ch[e++]='-';
                    }
                }
                else if(s[i]>='G' && s[i]<='I' )
                {
                    ch[e++]='4';
                    if(e==3)
                    {
                        ch[e++]='-';
                    }
                }
                else if(s[i]>='J' && s[i]<='L' )
                {
                    ch[e++] = '5';
                    if(e==3)
                    {
                        ch[e++]='-';
                    }
                }
                else if(s[i]>='M' && s[i]<='O' )
                {
                    ch[e++]='6';
                    if(e==3)
                    {
                        ch[e++]='-';
                    }
                }
                else if(s[i]=='P' || s[i]=='R' ||s[i]=='S' )
                {
                    ch[e++] = '7';
                    if(e==3)
                    {
                        ch[e++]='-';
                    }
                }
                else if(s[i]>='T' && s[i]<='V')
                {
                    ch[e++]='8' ;
                    if(e==3)
                    {
                        ch[e++]='-';
                    }
                }
                else if(s[i]>='W' && s[i]<='Y' )
                {
                    ch[e++]= '9';
                    if(e==3)
                    {
                        ch[e++]='-';
                    }
                }
            }
            ch[e]='\0';
            ma[ch]++;
        }
        for(it=ma.begin(); it!=ma.end(); it++)
        {
            if(it->second >1)
            {
               sum++;
               printf("%s %d\n", it->first.c_str(), it->second );
            }
        }
        if(sum==0)
        {
            printf("No duplicates.\n");
        }
    }
    return 0;
}

 


posted @   我喜欢旅行  阅读(179)  评论(0编辑  收藏  举报
编辑推荐:
· 智能桌面机器人:用.NET IoT库控制舵机并多方法播放表情
· Linux glibc自带哈希表的用例及性能测试
· 深入理解 Mybatis 分库分表执行原理
· 如何打造一个高并发系统?
· .NET Core GC压缩(compact_phase)底层原理浅谈
阅读排行:
· DeepSeek火爆全网,官网宕机?本地部署一个随便玩「LLM探索」
· 开发者新选择:用DeepSeek实现Cursor级智能编程的免费方案
· 【译】.NET 升级助手现在支持升级到集中式包管理
· 独立开发经验谈:如何通过 Docker 让潜在客户快速体验你的系统
· 并发编程 - 线程同步(二)
点击右上角即可分享
微信分享提示