n个数的最小公倍数
Description
求n个数的最小公倍数。
Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。
Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。
Sample Input
2 4 6
3 2 5 7
Sample Output
12
70
#include<stdio.h>
int GCD(int num, int x)
{
if(num%x==0)
return x;
return GCD(x, num%x);
}
int main ()
{
int n, x;
long long num;
while (scanf("%d", &n)!= EOF)
{
num = 1;
while (n--)
{
scanf ("%d", &x);
num = x/GCD(num,x)*num;
}
printf("%lld\n", num);
}
return 0;
}
用自己的努力创造我们的未来