AtCoder Grand Contest 008 A

Problem Statement

Snuke has a calculator. It has a display and two buttons.

Initially, the display shows an integer x. Snuke wants to change this value into another integer y, by pressing the following two buttons some number of times in arbitrary order:

  • Button A: When pressed, the value on the display is incremented by 1.
  • Button B: When pressed, the sign of the value on the display is reversed.

Find the minimum number of times Snuke needs to press the buttons to achieve his objective. It can be shown that the objective is always achievable regardless of the values of the integers x and y.

Constraints

  • x and y are integers.
  • |x|,|y|≤109
  • x and y are different.

Input

The input is given from Standard Input in the following format:

x y

Output

Print the minimum number of times Snuke needs to press the buttons to achieve his objective.


Sample Input 1

Copy
10 20

Sample Output 1

Copy
10

Press button A ten times.


Sample Input 2

Copy
10 -10

Sample Output 2

Copy
1

Press button B once.


Sample Input 3

Copy
-10 -20

Sample Output 3

Copy
12

Press the buttons as follows:

  • Press button B once.
  • Press button A ten times.
  • Press button B once.                     

题意:告诉我们两个数字,两种操作,一种是+1,一种是改变正负,问最小进行几次操作可以将x变成y

解法:讨论讨论讨论。。。。(注意等于0的情况)

复制代码
#include <bits/stdc++.h>
using namespace std;
#define ll long long
int main()
{
    ll n,m;
    cin>>n>>m;
//   cout<<min(abs(m-n),min(abs(-1*n-m)+1,min(abs(-1*n+m)+1,min(abs(-1*n+m)+2,abs(-1*n-m)+2))))<<endl;
   // if(n==m) continue;
   // cout<<n<<" "<<m<<" ";
      if(n<m)
            {
                ll pos=n*(-1);
                if(n>=0&&m>=0)
                {
                    //3 5
                    cout<<m-n<<endl;
                }
                else if(n<=0&&m>=0)
                {
                    //-3 5
                    //3 5
                    //-3 2
                    //-3+1=-2 2
                    if(pos<=m)
                    {
                        if(n!=0)
                        {
                            cout<<m-pos+1<<endl;
                        }
                        else
                        {
                            cout<<m-pos<<endl;
                        }
                    }
                    else
                    {
                        // cout<<"A"<<endl;
                        //ll ans=pos-m;
                        if(m==0)
                        {
                            cout<<pos<<endl;
                        }
                        else
                            cout<<pos-m+1<<endl;
                    }
                }
                else if(n<=0&&m<=0)
                {
                    //-3 -2
                    cout<<pos+m<<endl;
                }
            }
            else
            {
                if(n>=0&&m>=0)
                {
                    //4 2
                    if(m!=0)
                    {
                        cout<<n-m+2<<endl;
                    }
                    else
                    {
                        cout<<n+m+1<<endl;
                    }
                }
                else if(n>=0&&m<=0)
                {
                    ll pos=-1*m;
                    if(n==0)
                    {
                        cout<<-1*m+1<<endl;
                    }
                    else
                    {
                        if(n<=pos)
                        {
                            cout<<pos-n+1<<endl;
                        }
                        else
                        {
                            cout<<n+m+1<<endl;
                        }
                    }
                }
                else
                {
                    if(n==0)
                    {
                        cout<<(-1)*m+1<<endl;
                    }
                    else
                    {
                        cout<<(-1)*m-(-1)*n+2<<endl;
                    }
                }
            }
    return 0;
}
复制代码

 

posted @   樱花落舞  阅读(461)  评论(0编辑  收藏  举报
编辑推荐:
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· Manus的开源复刻OpenManus初探
· AI 智能体引爆开源社区「GitHub 热点速览」
· 从HTTP原因短语缺失研究HTTP/2和HTTP/3的设计差异
· 三行代码完成国际化适配,妙~啊~
历史上的今天:
2015-12-25 2015苏州大学ACM-ICPC集训队选拔赛(1) 1008
2015-12-25 2015苏州大学ACM-ICPC集训队选拔赛(1) 1007
2015-12-25 2015苏州大学ACM-ICPC集训队选拔赛(1) 1006
2015-12-25 2015苏州大学ACM-ICPC集训队选拔赛(1) 1005
2015-12-25 2015苏州大学ACM-ICPC集训队选拔赛(1) 1001 1002 1010
点击右上角即可分享
微信分享提示