HDU1085 Holding Bin-Laden Captive!

Description

We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
Output

 output the minimum positive value that one cannot pay with given coins, one line for one case.

Sample Input

1 1 3

0 0 0

Sample Output

4

母函数,注意的是每一个式子不是无限的,所以要加上一个cot<=b和cot<=c表示一个式子只有b,c项,不要超过了
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int c1[100000],c2[100000];
int main()
{
    int a,b,c;
    int num;
    while(cin>>a>>b>>c)
    {
        memset(c1,0,sizeof(c1));
        memset(c2,0,sizeof(c2));
        if(a==0&&b==0&&c==0) break;
        for(int i=0;i<=a;i++)
        {
            c1[i]=1;
        }
        num = a+2*b+5*c;
        int k,cot;
        for(int j=0;j<=num;j++)
        {
            for(k=0,cot=0;k+j<=num&&cot<=b;k+=2,cot++)
            {
                c2[j+k]+=c1[j];
            }
        }
        for(int j=0; j<=num; j++)
        {
            c1[j] = c2[j];
            c2[j] =0;
        }
        for(int j=0; j<=num; j++)
        {
            for(k=0,cot=0; k+j<=num&&cot<=c; k+=5,cot++)
            {
                c2[j+k]+=c1[j];
            }
        }
        for(int j=0; j<=num; j++)
        {
            c1[j] = c2[j];
            c2[j] =0;
        }
        int i;
        for(i=1;;i++)
        {
            if(!c1[i])
            {
                break;
            }
        }
        cout<<i<<endl;
    }
    return 0;
}

 

 

posted @ 2016-05-02 22:06  樱花落舞  阅读(177)  评论(0编辑  收藏  举报