HDU 3342 Legal or Not(有向图判环 拓扑排序)

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11382    Accepted Submission(s): 5346


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 

 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

 

Sample Input
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

 

Sample Output
YES NO
 

 

Author
QiuQiu@NJFU
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  3333 3341 3336 1811 3335 
 
判环,自身环不算,自己指向自己
code:
复制代码
#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
#include<set>
#include<map>
#include<list>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long LL;
int mon1[13]= {0,31,28,31,30,31,30,31,31,30,31,30,31};
int mon2[13]= {0,31,29,31,30,31,30,31,31,30,31,30,31};
int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};

int getval()
{
    int ret(0);
    char c;
    while((c=getchar())==' '||c=='\n'||c=='\r');
    ret=c-'0';
    while((c=getchar())!=' '&&c!='\n'&&c!='\r')
        ret=ret*10+c-'0';
    return ret;
}

#define max_v 105
int indgree[max_v];
vector<int> vv[max_v];
int n,m;
queue<int> q;
int tpsort()
{
    while(!q.empty())
        q.pop();
    for(int i=1;i<=n;i++)
        if(indgree[i]==0)
             q.push(i);
    int c=0;
    int temp;
    while(!q.empty())
    {
        temp=q.front();
        q.pop();
        c++;
        for(int i=0;i<vv[temp].size();i++)
        {
            indgree[vv[temp][i]]--;
            if(indgree[vv[temp][i]]==0)
                q.push(vv[temp][i]);
        }
    }
    if(c!=n)//判环 拓扑完之后,如果存在点没有入队,那么这个点一定是环上的
        return 1;
    else
        return 0;
}
int main()
{
    /*
    有向图判环 拓扑排序
    无向图判环 并查集 
    */
    int x,y;
    while(~scanf("%d %d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        memset(indgree,0,sizeof(indgree));
        for(int i=1;i<=n;i++)
            vv[i].clear();
        int flag=0;
        for(int i=1;i<=m;i++)
        {
            scanf("%d %d",&x,&y);
            x++,y++;
            if(x==y)
                continue;
            if(count(vv[x].begin(),vv[x].end(),y)==0)//防重边
            {
                vv[x].push_back(y);
                indgree[y]++;
            }
            if(count(vv[y].begin(),vv[y].end(),x)!=0)//环的一种
            {
                flag=1;
            }
        }
        flag=tpsort();
        if(flag)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}
复制代码

 

 
posted @   西*风  阅读(303)  评论(0编辑  收藏  举报
编辑推荐:
· DeepSeek 解答了困扰我五年的技术问题
· 为什么说在企业级应用开发中,后端往往是效率杀手?
· 用 C# 插值字符串处理器写一个 sscanf
· Java 中堆内存和栈内存上的数据分布和特点
· 开发中对象命名的一点思考
阅读排行:
· DeepSeek 解答了困扰我五年的技术问题。时代确实变了!
· PPT革命!DeepSeek+Kimi=N小时工作5分钟完成?
· What?废柴, 还在本地部署DeepSeek吗?Are you kidding?
· DeepSeek企业级部署实战指南:从服务器选型到Dify私有化落地
· 程序员转型AI:行业分析
点击右上角即可分享
微信分享提示