ZOJ 3992 One-Dimensional Maze(思维题)

L - One-Dimensional Maze
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

BaoBao is trapped in a one-dimensional maze consisting of n grids arranged in a row! The grids are numbered from 1 to n from left to right, and the i-th grid is marked with a character si, where si is either 'L' or 'R'.

Starting from the m-th grid, BaoBao will repeatedly take the following steps until he escapes the maze:

  • If BaoBao is in the 1st grid or the n-th grid, then BaoBao is considered to arrive at the exit and thus can escape successfully.
  • Otherwise, let BaoBao be in the t-th grid. If st='L', BaoBao will move to the (t1)-th grid; If st='R', Baobao will move to the (t+1)-th grid.

Before taking the above steps, BaoBao can change the characters in some grids to help himself escape. Concretely speaking, for the i-th grid, BaoBao can change si from 'L' to 'R', or from 'R' to 'L'.

But changing characters in grids is a tiring job. Your task is to help BaoBao calculate the minimum number of grids he has to change to escape the maze.

Input

There are multiple test cases. The first line of the input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (3n105, 1<m<n), indicating the number of grids in the maze, and the index of the starting grid.

The second line contains a string s (|s|=n) consisting of characters 'L' and 'R'. The i-th character of s indicates the character in the i-th grid.

It is guaranteed that the sum of n over all test cases will not exceed 106.

Output

For each test case output one line containing one integer, indicating the minimum number of grids BaoBao has to change to escape the maze.

Sample Input

3
3 2
LRL
10 4
RRRRRRRLLR
7 4
RLLRLLR

Sample Output

0
2
1

Hint

For the first sample test case, BaoBao doesn't have to change any character and can escape from the 3rd grid. So the answer is 0.

For the second sample test case, BaoBao can change s8 to 'R' and s9 to 'R' and escape from the 10th grid. So the answer is 2.

For the third sample test case, BaoBao can change s4 to 'L' and escape from the 1st grid. So the answer is 1.

 

题意:给出一串只有RL的字符串,
给定起始位置,R表示向右,L表示向左,
现在要求输出最少改变几个字符可以移动到字符第一个或者最后一个。
例如:
6 3
LLRRLR
起始位置是第三个字符R,只用改变第三个R就可以到达第一个字符L
这道题目通过模拟就可以做出来,
就是将到达两边要改变的字符都求出来,输出最小的那个
 
复制代码
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define max_v 100005
char str[max_v];
/*
Submit Failed
*/
int main()
{
    int t;
    int n,m,sum1,sum2;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&m);
        scanf("%s",str+1);
        sum1=0;
        sum2=0;
        for(int i=m;i<n;i++)
            if(str[i]=='L')
               sum1++;
        for(int i=m;i>1;i--)
            if(str[i]=='R')
            sum2++;
        printf("%d\n",min(sum1,sum2));
    }
    return 0;
}
/*
题意:给出一串只有RL的字符串,
给定起始位置,R表示向右,L表示向左,
现在要求输出最少改变几个字符可以移动到字符第一个或者最后一个。 
例如: 
6 3 
LLRRLR 

起始位置是第三个字符R,只用改变第三个R就可以到达第一个字符L 
这道题目通过模拟就可以做出来,
就是将到达两边要改变的字符都求出来,输出最小的那个 

*/
复制代码

 

 
posted @   西*风  阅读(264)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
点击右上角即可分享
微信分享提示