ZOJ 3203 Light Bulb (三分+计算几何)

B - Light Bulb
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

 

Input

 

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

 

Output

 

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

 

Sample Input

 

 

3
2 1 0.5
2 0.5 3
4 3 4

 

 

Sample Output

 

 

1.000
0.750
4.000
题目意思:
给你H,h,D三个数字
问你影子的长度
随着h的变化,影子的长度也会变化(影子的长度包括在地上和墙上的)
可以预想一下
跟h有关的影子的长度的函数是一个由峰值的函数
所以三分解决
 
复制代码
#include<cstdio>
#include<string>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<cstring>
#include<set>
#include<queue>
#include<algorithm>
#include<vector>
#include<map>
#include<cctype>
#include<stack>
#include<sstream>
#include<list>
#include<assert.h>
#include<bitset>
#include<numeric>
#define max_v 35
#define eps 10e-6
using namespace std;
double H,h,D;
double f(double l)
{
    return D*(h-l)/(H-l)+l;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf %lf %lf",&H,&h,&D);
        double l=0,r=h;
        double mid,mmid;
        while(fabs(l-r)>eps)
        {
            mid=(l+r)/2;
            mmid=(mid+r)/2;
            if(f(mid)<=f(mmid))
            {
                l=mid;
            }
            else
            {
                r=mmid;
            }
        }
        printf("%0.3lf\n",f(l));
    }
    return 0;
}
/*
题目意思:
给你H,h,D三个数字
问你影子的长度

随着h的变化,影子的长度也会变化(影子的长度包括在地上和墙上的)
可以预想一下
跟h有关的影子的长度的函数是一个由峰值的函数
所以三分解决

*/
复制代码

 

 
posted @   西*风  阅读(203)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
点击右上角即可分享
微信分享提示