ZOJ 2476 Total Amount 字符串模拟

- Total Amount
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Given a list of monetary amounts in a standard format, please calculate the total amount.

We define the format as follows:

1. The amount starts with '$'.

2. The amount could have a leading '0' if and only if it is less then 1.

3. The amount ends with a decimal point and exactly 2 following digits.

4. The digits to the left of the decimal point are separated into groups of three by commas (a group of one or two digits may appear on the left).

 

Input

 

The input consists of multiple tests. The first line of each test contains an integer N (1 <= N <= 10000) which indicates the number of amounts. The next N lines contain N amounts. All amounts and the total amount are between 0.00and20,000,000.00, inclusive. N=0 denotes the end of input.

 

Output

 

For each input test, output the total amount.

 

Sample Input

 

2
1,234,567.899,876,543.21
3
0.010.10
$1.00
0

 

Sample Output

 

11,111,111.101.11

 
复制代码
#include<bits/stdc++.h>
using namespace std;
const int maxn=1e+5+5;
char a[maxn];
int c[maxn],d[maxn],ans[maxn];
int main()
{
    int T;
    while(~scanf("%d",&T) && T)
    {
        memset(ans,0,sizeof(ans));
        memset(d,0,sizeof(d));
        int index,cnt=0;
        while(T--)
        {
            memset(c,0,sizeof(c));
            memset(a,0,sizeof(a));
            scanf("%s",a);
            int k=0;
            for(int i=0; i<strlen(a); i++)
            {
                if(isdigit(a[strlen(a)-i-1]))
                    c[k++]=a[strlen(a)-i-1]-'0';
            }
            for(int i=0; i<100; i++)
            {
                d[i]+=c[i];
                d[i+1]+=d[i]/10;
                d[i]%=10;
            }
        }
        for(int i=100; i>=0; i--)
        {
            if(d[i]!=0)
            {
                index=i;
                break;
            }
        }
        for(int i=index; i>=2; i--)
            ans[cnt++]=d[i];
        printf("$");
        if(cnt==0)printf("0");
        else
        {
            for(int i=0; i<cnt; i++)
            {
                printf("%d",ans[i]);
                if((cnt-i-1)%3==0 && i!=cnt-1)
                    printf(",");
            }
        }
        printf(".%d%d\n",d[1],d[0]);
    }
    return 0;
}
复制代码

 

posted @   西*风  阅读(194)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
点击右上角即可分享
微信分享提示