HDU 1698 Just a Hook(线段树模板之区间替换更新,区间求和查询)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 43184    Accepted Submission(s): 20748


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

 

Sample Input
1 10 2 1 5 2 5 9 3
 

 

Sample Output
Case 1: The total value of the hook is 24.
 

 

Source
 

 

Recommend
wangye   |   We have carefully selected several similar problems for you:  1166 1542 1394 2795 1255 
 
题目意思:
一个钩子,有n段,开始每一段的价值是1
q给更新操作
a,b,c
a段开始到b段 价值全部替换为c
问你最后钩子的总价值是多少
code:
复制代码
#include<stdio.h>
#include<iostream>
#include<vector>
#include <cstring>
#include <stack>
#include <cstdio>
#include <cmath>
#include <queue>
#include <algorithm>
#include <vector>
#include <set>
#include <map>
#include<string>
#include<math.h>
#define max_v 100005
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long LL;
LL sum[max_v<<2],add[max_v<<2];
struct node
{
    int l,r;
    int mid()
    {
        return (l+r)/2;
    }
}tree[max_v<<2];

void push_up(int rt)//向上更新
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void push_down(int rt,int m)//向下更新
{
    if(add[rt])//若有标记,则将标记向下移动一层
    {
        add[rt<<1]=add[rt];
        add[rt<<1|1]=add[rt];

        sum[rt<<1]=add[rt]*(m-(m>>1));
        sum[rt<<1|1]=add[rt]*(m>>1);
        add[rt]=0;//取消本层标记
    }
}
void build(int l,int r,int rt)
{
    tree[rt].l=l;
    tree[rt].r=r;
    add[rt]=0;

    if(l==r)
    {
        sum[rt]=1;
        //scanf("%I64d",&sum[rt]);
        return ;
    }

    int m=tree[rt].mid();
    build(lson);
    build(rson);
    push_up(rt);//向上更新
}
void update(int c,int l,int r,int rt)
{
    if(tree[rt].l==l&&tree[rt].r==r)
    {
        add[rt]=c;
        sum[rt]=(LL)c*(r-l+1);
        return ;
    }

    if(tree[rt].l==tree[rt].r)
        return ;

    push_down(rt,tree[rt].r-tree[rt].l+1);//向下更新

    int m=tree[rt].mid();
    if(r<=m)
        update(c,l,r,rt<<1);
    else if(l>m)
        update(c,l,r,rt<<1|1);
    else
    {
        update(c,l,m,rt<<1);
        update(c,m+1,r,rt<<1|1);
    }
    push_up(rt);//向上更新
}
LL getsum(int l,int r,int rt)
{
    if(tree[rt].l==l&&tree[rt].r==r)
        return sum[rt];

    push_down(rt,tree[rt].r-tree[rt].l+1);//向下更新

    int m=tree[rt].mid();
    LL res=0;
    if(r<=m)
        res+=getsum(l,r,rt<<1);
    else if(l>m)
        res+=getsum(l,r,rt<<1|1);
    else
    {
        res+=getsum(l,m,rt<<1);
        res+=getsum(m+1,r,rt<<1|1);
    }
    return res;
}
int main()
{
    int n,m;
    int t;
    int a,b,c;
    int cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        build(1,n,1);
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d %d %d",&a,&b,&c);
            update(c,a,b,1);
        }
        printf("Case %d: The total value of the hook is %I64d.\n", cas++,getsum(1,n,1));
    }
    return 0;
}
/*
题目意思:
一个钩子,有n段,开始每一段的价值是1
q给更新操作
a,b,c
a段开始到b段 价值全部替换为c
问你最后钩子的总价值是多少


区间更新:替换更新
区间查询:求和
*/
复制代码

 

posted @   西*风  阅读(193)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
点击右上角即可分享
微信分享提示