POJ 3661 Running(区间dp)

传送门:

http://poj.org/problem?id=3661

Running
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7761   Accepted: 2899

Description

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her 'exhaustion factor', which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches 0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie's exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.
 

Sample Input

5 2
5
3
4
2
10

Sample Output

9

Source

 

题目意思:

给你N分钟,每一分钟可以走Di的路程,同时每分钟增加1的疲劳度,
最多不能超过M疲劳度,对于每一分钟你就可以选择跑或者休息,
如果休息的话只能休息到疲劳度为0的时候才能继续跑,
问这N分钟你可以走的最远路程并且疲劳度为0

 

分析:

思路:我们令dp[i][j]为第i分钟疲劳度为j时候走的最大路程,
那么显然对于每一分钟有两种决策,要么跑,
那么dp[i][j]=dp[i-1][j-1]+d[i],要么选择休息,
那么dp[i][0]=max(dp[i-j][j]),
同时注意当疲劳度为0的时候我也可以继续休息,
那么dp[i][0]=dp[i-1][0],然后就转移吧

 

code:

复制代码
#include <iostream>
#include<algorithm>
#include <cstdio>
#include<cstring>
using namespace std;
#define max_v 10005
int dp[max_v][max_v];//dp[i][j]为第i分钟疲劳度为j时候走的最大路程
int a[max_v];
int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        dp[0][0]=0;
        for(int i=1;i<=n;i++)
        {
            dp[i][0]=dp[i-1][0];//疲劳度为0时继续选择休息

            for(int j=1;j<=m;j++)
            {
                if(i>j)
                    dp[i][0]=max(dp[i-j][j],dp[i][0]);//第i分钟选择休息j分钟

                dp[i][j]=dp[i-1][j-1]+a[i];//第i分钟选择跑
            }
        }
        printf("%d\n",dp[n][0]);
    }
    return 0;
}
复制代码

 

 

posted @   西*风  阅读(364)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
点击右上角即可分享
微信分享提示