HDU 1045 Fire Net(DFS 与8皇后问题类似)

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14780    Accepted Submission(s): 8932


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
 

 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

 

Sample Input
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

 

Sample Output
5 1 5 2 4
 

 

Source
 

 

Recommend
We have carefully selected several similar problems for you:  1051 1067 1052 1072 1195 

 

题目意思:

题目给出一个n和一幅N*N的图,图中包含'.','X'两种字符,

要求在上面放上碉堡,碉堡能攻击他所在的行和列,但不能攻击墙,求最多能放多少个碉堡.

X是墙,不能放炮台

与八皇后类似,炮台不能存在于同行同列,除非中间隔墙

直接dfs

 

code:

复制代码
#include <stdio.h>
#include <iostream>
#include <stdlib.h>
#include <algorithm>
#include <string.h>
using namespace std;
char G[5][5];
int n,sum;
bool check(int x,int y)//检查该点能不能放炮台
{
    if(G[x][y]=='X')//该点是墙,不能放直接退出
        return false;
    for(int i=x;i<n;i++)//判断该点的下面不能右炮台(除非有墙)
    {
        if(G[i][y]=='X')
            break;
        if(G[i][y]=='S')
            return false;
    }
    for(int i=x;i>=0;i--)//
    {
        if(G[i][y]=='X')
            break;
        if(G[i][y]=='S')
            return false;
    }
    for(int j=y;j<n;j++)//
    {
        if(G[x][j]=='X')
            break;
        if(G[x][j]=='S')
            return false;
    }
    for(int j=y;j>=0;j--)//
    {
        if(G[x][j]=='X')
            break;
        if(G[x][j]=='S')
            return false;
    }
    return true;
}
void dfs(int k)
{
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            if(check(i,j))
            {
                G[i][j]='S';
                dfs(k+1);
                G[i][j]='.';
            }
        }
    }
    if(sum<k)
        sum=k;
}
int main()
{
    while(cin>>n,n)
    {
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                cin>>G[i][j];
            }
        }
        sum=0;
        dfs(0);
        cout<<sum<<endl;
    }
    return 0;
}
复制代码

 

posted @   西*风  阅读(242)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
点击右上角即可分享
微信分享提示