hdu 1021 Fibonacci Again(变形的斐波那契)

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1021

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 70782    Accepted Submission(s): 32417


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

 

Sample Input
0 1 2 3 4 5
 

 

Sample Output
no no yes no no no
 

 

Author
Leojay
 

 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1061 1108 1071 1049 1032 
 
分析:
别多想
直接暴力即可,开始还想找规律来着
注意求第i项的时刻记得模3
不然会溢出(w了两次。。。gg)
 
code:
#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
#define max_v 1000005
LL f[max_v];
int main()
{
    f[0]=7;
    f[1]=11;
    for(LL i=2;i<max_v;i++)
    {
        f[i]=(f[i-1]%3+f[i-2]%3)%3;
    }
    LL n;
    while(~scanf("%I64d",&n))
    {
        if(f[n]%3==0)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}

 

 

posted @ 2018-07-15 13:53  西*风  阅读(340)  评论(0编辑  收藏  举报