HDU 1017A Mathematical Curiosity (暴力统计特殊要求个数)

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1017

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47658    Accepted Submission(s): 15285


Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

 

Sample Input
1 10 1 20 3 30 4 0 0
 

 

Sample Output
Case 1: 2 Case 2: 4 Case 3: 5
 

 

Source
分析:
直接暴力即可
code:
复制代码
#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
#define max_v 105
int main()
{
    int t;
    int n,m;
    scanf("%d",&t);
    while(t--)
    {
        int k=1;
        while(~scanf("%d %d",&n,&m))
        {
            if(n==0&&m==0)
                break;
            int c=0;
            //直接暴力即可
            for(int i=1; i<n-1; i++)
            {
                for(int j=i+1; j<n; j++)
                {
                    if((i*i+j*j+m)%(i*j)==0)
                        c++;
                }
            }
            printf("Case %d: %d\n",k++,c);
        }
        if(t!=0)
            printf("\n");
    }
    return 0;
}
复制代码

 

posted @   西*风  阅读(252)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
点击右上角即可分享
微信分享提示