HDU 1007 Quoit Design(经典最近点对问题)

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1007

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 62916    Accepted Submission(s): 16609


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.
 

 

Sample Input
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

 

Sample Output
0.71 0.00 0.75
 

 

Author
CHEN, Yue
 

 

Source
 
题目意思:
给你一个点的集合,问你距离最近的两个点的距离的一半是多少
非常经典的最近点对问题
第一次写
还不是很理解呃
分治
code:
复制代码
#include<bits/stdc++.h>
using namespace std;
#define max_v 100005
int n;
struct node
{
    double x,y;
}p[max_v];
int a[max_v];
double cmpx(node a,node b)
{
    return a.x<b.x;
}
double cmpy(int a,int b)
{
    return p[a].y<p[b].y;
}
double min_f(double a,double b)
{
    return a<b?a:b;
}
double dis(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double slove(int l,int r)
{
    if(r==l+1)
        return dis(p[l],p[r]);
    if(l+2==r)
        return min_f(dis(p[l],p[r]),min_f(dis(p[l],p[l+1]),dis(p[l+1],p[r])));
    int mid=(l+r)>>1;
    double ans=min_f(slove(l,mid),slove(mid+1,r));
    int i,j,cnt=0;
    for( i=l;i<=r;i++)
    {
        if(p[i].x>=p[mid].x-ans&&p[i].x<=p[mid].x+ans)
        {
            a[cnt++]=i;
        }
    }
    sort(a,a+cnt,cmpy);
    for(i=0;i<cnt;i++)
    {
        for(j=i+1;j<cnt;j++)
        {
            if(p[a[j]].y-p[a[i]].y>=ans)
                break;
            ans=min_f(ans,dis(p[a[i]],p[a[j]]));
        }
    }
    return ans;
}
int main()
{
    int i;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        for(i=0;i<n;i++)
        {
            scanf("%lf %lf",&p[i].x,&p[i].y);
        }
        sort(p,p+n,cmpx);
        printf("%0.2lf\n",slove(0,n-1)/2.0);
    }
    return 0;
}
复制代码

 

posted @   西*风  阅读(357)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
点击右上角即可分享
微信分享提示