HDU3371 最小生成树

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=3371

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24179    Accepted Submission(s): 5509


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

 

Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6
 

 

Sample Output
1
 

 

Author
dandelion
 

 

Source
 
分析:
最小生成树,稠密图采用prim算法
注意重边的情况
这个题写了很久,不是wa而是超时,最后发现不能memset,不能采用万能头文件
顺便吐槽一下HDU,交同一个代码ac和tl概率1比1
如果你发现我的代码提交超时,别慌,多提交几次就过了。。。
很魔性
代码如下:
复制代码
#include<stdio.h>
using namespace std;
#define max_v 505
#define INF 100000
int g[max_v][max_v];
int n,m,k;
int sum;
void init()
{
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        g[i][j]=INF;
}
void prim()
{
    int lowcost[n];
    int used[n];
    for(int i=0;i<n;i++)
    {
        lowcost[i]=g[0][i];
        used[i]=0;
    }
    used[0]=1;
    for(int i=1;i<n;i++)
    {
        int j=0;
        for(int k=0;k<n;k++)
        {
            if(!used[k]&&lowcost[k]<lowcost[j])
                j=k;
        }
        sum+=lowcost[j];
        used[j]=1;
        for(int k=0;k<n;k++)
        {
            if(!used[k]&&g[j][k]<lowcost[k])
            {
                lowcost[k]=g[j][k];
            }
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%d %d %d",&n,&m,&k);
        init();
        for(int i=0;i<m;i++)
        {
            int a,b,c;
            scanf("%d %d %d",&a,&b,&c);
            g[a-1][b-1]=c;
            g[b-1][a-1]=c;
        }
        for(int i=0;i<k;i++)
        {
            int a,x,y;
            scanf("%d",&a);
            scanf("%d",&x);
            a--;
            while(a--)
            {
                scanf("%d",&y);
                g[x-1][y-1]=0;
                g[y-1][x-1]=0;
            }
        }
        prim();
        printf("%d\n",sum);
    }
    return 0;
}
复制代码

 

posted @   西*风  阅读(191)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
点击右上角即可分享
微信分享提示