HDU 2298(纯物理加解一元二次方程)

Toxophily

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2555    Accepted Submission(s): 1416


Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m.
 

 

Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.
Technical Specification

1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000.
 

 

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output "-1", if there's no possible answer.

Please use radian as unit.
 

 

Sample Input
3
0.222018 23.901887 121.909183
39.096669 110.210922 20.270030
138.355025 2028.716904 25.079551
 

 

 

Sample Output
1.561582
-1
-1
 解题报告:
二分三分什么的好麻烦啊。。。。。。。。。。。。。。。。
直接按照做物理题的思路:

代码如下:

复制代码
#include<bits/stdc++.h>
using namespace std;
const double PI=3.1415926535898;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double x,y,v;
        scanf("%lf %lf %lf",&x,&y,&v);
        if(x==0)//考虑特殊情况
        {
            if(y==0)
                printf("0.000000\n");
            else
                printf("%lf\n",PI/2);
                continue;
        }
        double t=x*x-4*(4.9)*(x*1.0/v*1.0)*(x*1.0/v*1.0)*(4.9*(x*1.0/v*1.0)*(x*1.0/v*1.0)+y);
        if(t>0)
        {
            double r;
            if(x>sqrt(t))
            {
                r=(x-sqrt(t))/(9.8*(x/v)*(x/v));
            }else
            {
                r=(x+sqrt(t))/(9.8*(x/v)*(x/v));
            }
            printf("%lf\n",atan(r));
        }else
        {
            printf("-1\n");
        }
    }
}
复制代码

 

 
 
 
posted @   西*风  阅读(171)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
点击右上角即可分享
微信分享提示