HDU1047(多个大数相加)

Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23291    Accepted Submission(s): 6564


Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
 

 

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
 

 

Output
Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

 

Sample Input
1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
 

 

Sample Output
370370367037037036703703703670
 
代码如下:
复制代码
#include<bits/stdc++.h>
using namespace std;
string add(string str1,string str2)
{
    int l1=str1.length();
    int l2=str2.length();
    if(l1>l2)
    {
        for(int i=0;i<l1-l2;i++)
        {
            str2="0"+str2;
        }
    }else if(l1<l2)
    {
        for(int i=0;i<l2-l1;i++)
        {
            str1="0"+str1;
        }
    }
    l1=str1.length();
    string str3;
    int c=0;
    for(int i=l1-1;i>=0;i--)
    {
        int temp=str1[i]-'0'+str2[i]-'0'+c;
        c=temp/10;
        temp=temp%10;
        str3=char(temp+'0')+str3;
    }
    if(c!=0)
    {
        str3=char(c+'0')+str3;
    }
    return str3;
}
int main()
{
    int n;
   scanf("%d",&n);
    while(n--)
    {
        string str;
        string sum="0";
        while(cin>>str)
        {
            if(str=="0")
                break;
            sum=add(sum,str);
        }
        cout<<sum<<endl;
        if(n>0)
            printf("\n");
    }
    return 0;
}
复制代码

 

posted @   西*风  阅读(165)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
点击右上角即可分享
微信分享提示