HDU 3592 World Exhibition(线性差分约束,spfa跑最短路+判断负环)

World Exhibition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2162    Accepted Submission(s): 1063


Problem Description
Nowadays, many people want to go to Shanghai to visit the World Exhibition. So there are always a lot of people who are standing along a straight line waiting for entering. Assume that there are N (2 <= N <= 1,000) people numbered 1..N who are standing in the same order as they are numbered. It is possible that two or more person line up at exactly the same location in the condition that those visit it in a group.

There is something interesting. Some like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of X (1 <= X <= 10,000) constraints describes which person like each other and the maximum distance by which they may be separated; a subsequent list of Y constraints (1 <= Y <= 10,000) tells which person dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between person 1 and person N that satisfies the distance constraints.
 

 

Input
First line: An integer T represents the case of test.

The next line: Three space-separated integers: N, X, and Y.

The next X lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= N. Person A and B must be at most C (1 <= C <= 1,000,000) apart.

The next Y lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= C. Person A and B must be at least C (1 <= C <= 1,000,000) apart.
 

 

Output
For each line: A single integer. If no line-up is possible, output -1. If person 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between person 1 and N.
 

 

Sample Input
1 4 2 1 1 3 8 2 4 15 2 3 4
 

 

Sample Output
19
 

 

Author
alpc20
 

 

Source
 

 

Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:  1534 1529 3666 3440 1531 
 
分析:
负环的定义:
有向图中存在一个环,其权值和为负数
这题跟poj3169一模一样
解析:
 
code:
复制代码
#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
#include<set>
#include<map>
#include<list>
#include<math.h>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long LL;
#define INF 9999999999
#define me(a,x) memset(a,x,sizeof(a))
int mon1[13]= {0,31,28,31,30,31,30,31,31,30,31,30,31};
int mon2[13]= {0,31,29,31,30,31,30,31,31,30,31,30,31};
int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};

int getval()
{
    int ret(0);
    char c;
    while((c=getchar())==' '||c=='\n'||c=='\r');
    ret=c-'0';
    while((c=getchar())!=' '&&c!='\n'&&c!='\r')
        ret=ret*10+c-'0';
    return ret;
}
void out(int a)
{
    if(a>9)
        out(a/10);
    putchar(a%10+'0');
}

#define max_v 1005
struct node
{
    int v;
    LL w;
    node(int vv=0,LL ww=0):v(vv),w(ww) {}
};
LL dis[max_v];
int vis[max_v];
int cnt[max_v];
vector<node> G[max_v];
queue<int> q;

void init()
{
    for(int i=0; i<max_v; i++)
    {
        G[i].clear();
        dis[i]=INF;
        vis[i]=0;
        cnt[i]=0;
    }
    while(!q.empty())
        q.pop();
}

int spfa(int s,int n)
{
    vis[s]=1;
    dis[s]=0;
    q.push(s);
    cnt[s]++;

    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        vis[u]=0;

        for(int j=0; j<G[u].size(); j++)
        {
            int v=G[u][j].v;
            LL w=G[u][j].w;

            if(dis[v]>dis[u]+w)
            {
                dis[v]=dis[u]+w;
                if(vis[v]==0)
                {
                    q.push(v);
                    cnt[v]++;
                    vis[v]=1;

                    if(cnt[v]>n)
                        return 0;
                }
            }
        }
    }
    return 1;
}
int f(int u,int v)
{
    for(int j=0; j<G[u].size(); j++)
    {
        if(G[u][j].v==v)
            return 0;
    }
    return 1;
}
int main()
{
    int n,a,b;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d %d",&n,&a,&b);
        init();
        int x,y,w;
        while(a--)
        {
            scanf("%d %d %d",&x,&y,&w);
            if(f(x,y))
                G[x].push_back(node(y,w));
        }
        while(b--)
        {
            scanf("%d %d %d",&x,&y,&w);
            if(f(y,x))
                G[y].push_back(node(x,-w));
        }
        int flag=spfa(1,n);
        if(flag==0)
        {
            printf("-1\n");
        }
        else if(dis[n]<INF)
        {
            printf("%lld\n",dis[n]);
        }
        else
        {
            printf("-2\n");
        }
    }
    return 0;
}
复制代码

 

 
posted @   西*风  阅读(288)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
点击右上角即可分享
微信分享提示