HDU 1045(质因数分解)

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.
 

Input

Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.
 

Output

For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.
 

Sample Input

60
12
-1
 

Sample Output

Case 1.
2 2 3 1 5 1
Case 2.
2 2 3 1

Hint

 60=2^2*3^1*5^1 

程序分析:由此题的标题就可以得知这个题目主要就是质因数分解,但是也一点要十分注意就是输出之间加一个空行,最后的那个数据不能加空行,还有,每组数据最后是有个空格的,不要忘记加上 不然你就会一直PE过不了的。

程序代码:

#include<stdio.h>
int prm[65536],a[70000]={0};
int main()
{
    int i,j,k,n,flag,num;
    k=0;
    for(i=2;i<=65536;i++)
        if(!a[i]){
            prm[k++]=i;
            for(j=i+i;j<=65536;j+=i)
                a[j]=1;
        }
        flag=0;
        while(1)
        { 
            scanf("%d",&n);
            if(n<0)break;
            if(flag)
                printf("\n");
            flag++;
            printf("Case %d.\n",flag);
            for(i=0;i<k&&prm[i]<=n;i++)
            {
                num=0;
                while(n%prm[i]==0){
                    num++;
                    n=n/prm[i];
                }
                if(num!=0){
                    if(n==1)printf("%d %d \n",prm[i],num);
                    else printf("%d %d ",prm[i],num);
                }
            }
        }
        return 0;
        
}

 

posted @ 2015-08-18 21:14  lee是美少女  阅读(452)  评论(0编辑  收藏  举报