poj_2084_Game of Connections

This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, . . . , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another.
And, no two segments are allowed to intersect.
It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?

Input

Each line of the input file will be a single positive number n, except the last line, which is a number -1.
You may assume that 1 <= n <= 100.

Output

For each n, print in a single line the number of ways to connect the 2n numbers into pairs.

Sample Input

2
3
-1

Sample Output

2
5

卡特兰数,链接是一个不错的介绍卡特兰相关题目的博客。
http://blog.163.com/lz_666888/blog/static/1147857262009914112922803/

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
#define MAX 100
#define BASE 10000
void multiply(int a[],int Max,int b) //大数乘法,注意参数的传递
{
    int i,array=0;
    for (i = Max-1; i >= 0; i--)
    {
        array += b * a[i];
        a[i] = array % BASE; // 数组每一位存放大数的四位数字
        array /= BASE;
    }
}
void divide(int a[], int Max, int b) //模拟大数除法
{
    int i, div = 0;
    for (i = 0; i < Max; i++)
    {
        div = div * BASE + a[i];
        a[i] = div / b;
        div %= b;
    }
}
int main()
{
    int a[101][MAX],i, n;
    memset(a[1],0,MAX*sizeof(int));
    for (i=2, a[1][MAX-1] = 1; i < 101; i++) // 高坐标存放大数低位
    {
        memcpy(a[i], a[i-1], MAX * sizeof(int));      //h[i] = h[i-1];
        multiply(a[i], MAX, 4 * i - 2);               //h[i] *= (4*i-2);
        divide(a[i], MAX, i + 1);                  //h[i] /= (i+1);
    }
    while (cin >> n&&n!=-1)
    {
        for (i = 0; i < MAX && a[n][i] == 0; i++); //去掉数组前为0的数字。
        cout << a[n][i++];             //输出第一个非0数
        for (; i < MAX; i++)
        {
    printf("%04d",a[n][i]);       //输出后面的数,并每位都保持4位长度!(32767)
   }
        cout << endl;
    }
    return 0;
}

  

posted @ 2017-12-14 21:36  会飞的雅蠛蝶  阅读(156)  评论(0编辑  收藏  举报