poj_2249_Binomial Showdown

In how many ways can you choose k elements out of n elements, not taking order into account?
Write a program to compute this number.

Input

The input will contain one or more test cases.
Each test case consists of one line containing two integers n (n>=1) and k (0<=k<=n).
Input is terminated by two zeroes for n and k.

Output

For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 2 31.
Warning: Don't underestimate the problem. The result will fit into an integer - but if all intermediate results arising during the computation will also fit into an integer depends on your algorithm. The test cases will go to the limit.

Sample Input

4 2
10 5
49 6
0 0

Sample Output

6
252
13983816

求C(n,k),模板题
#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
#define ll long long
#define M 105

ll n,k;

int main()
{
    ll i,j;
    while(cin>>n>>k)
    {
        if(n==0&&k==0)
            break;
        if(k==n)
        {
            cout<<1<<endl;
            continue;
        }

        if(n-k<k)
            k=n-k;
        ll ans=1;
        for(i=1;i<=k;i++)
        {
            ans=ans*(n-i+1)/i;
        }
        cout<<ans<<endl;
    }
}

  

posted @ 2017-12-14 21:07  会飞的雅蠛蝶  阅读(168)  评论(0编辑  收藏  举报