poj_3256_Cow Picnic

The cows are having a picnic! Each of Farmer John's K (1 ≤ K ≤ 100) cows is grazing in one of N (1 ≤ N ≤ 1,000) pastures, conveniently numbered 1...N. The pastures are connected by M (1 ≤ M ≤ 10,000) one-way paths (no path connects a pasture to itself).

The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.

Input

Line 1: Three space-separated integers, respectively: K, N, and M
Lines 2.. K+1: Line i+1 contains a single integer (1.. N) which is the number of the pasture in which cow i is grazing.
Lines K+2.. M+ K+1: Each line contains two space-separated integers, respectively A and B (both 1.. N and A != B), representing a one-way path from pasture A to pasture B.

Output

Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.

Sample Input

2 4 4
2
3
1 2
1 4
2 3
3 4

Sample Output

2

Hint

The cows can meet in pastures 3 or 4.
 
dfs题,搜索每只牛能到达的位置。
 
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 1000005
int prime[N];
int pn=0;
int vis[10005];
int st[10005];
int val[10005];
int a[10005];
int b[10005];
int h[10005];
int k,n,m;
void dfs(int x)
{
    val[x]=1;vis[x]++;
    for(int i=h[x];i;i=a[i])
    {
            if(!val[b[i]])
                dfs(b[i]);

    }
}
int main()
{
    //int k,n,m;
    cin>>k>>n>>m;
    int num=0;
    for(int i=1;i<=k;i++)
    {
        cin>>st[i];
        //vis[st[i]]++;
    }
    int x,y;
    for(int i=1;i<=m;i++)
    {
        cin>>x>>y;
        a[i]=h[x];
        b[i]=y;
        h[x]=i;

    }
    for(int i=1;i<=k;i++)
    {
        memset(val,0,sizeof(val));
        dfs(st[i]);
    }
    for(int i=1;i<=n;i++)
    {
        if(vis[i]==k)
            num++;
    }
    cout<<num<<endl;
}

  

posted @ 2017-12-14 21:06  会飞的雅蠛蝶  阅读(129)  评论(0编辑  收藏  举报