poj_1730_Perfect Pth Powers

We say that x is a perfect square if, for some integer b, x = b 2. Similarly, x is a perfect cube if, for some integer b, x = b 3. More generally, x is a perfect pth power if, for some integer b, x = b p. Given an integer x you are to determine the largest p such that x is a perfect p th power.

Input

Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the largest integer p such that x is a perfect p th power.

Sample Input

17
1073741824
25
0

Sample Output

1
30
2




一点都不难但是很讨厌的一道题,很烦的地方就是输入可以为负,没有处理搞了半天runtime error。
然后输入用longlong。
对于输入为负的数字。例64=2^6,然而-64=(-4)^3。
综上,负数的output只能为奇数
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
#define N 100001
using namespace std;
typedef long long ll;
bool vis[N];
int prime[N];
int pn=0;
int gcd(int a,int b)
{
    if(!b) return a;
    return gcd(b,a%b);
}
int main()
{
    for (int i = 2; i < N; i++) {
        if (vis[i]) continue;
        prime[pn++] = i;
    for (int j = i; j < N; j += i)
            vis[j]=1;
    }
    ll n;
    while(~scanf("%lld",&n),n)
    {
        ll r=n>0?n:-n;
        int ans=0;
        for(int i=0;(long long)prime[i]*prime[i]<=r;i++)
        {
            int tem=0;
            while(r%prime[i]==0)
            {
                r/=prime[i];
                tem++;
            }
            if(tem)
                ans=gcd(ans,tem);
        }
        if(r!=1&&ans)
            ans=gcd(ans,r);
        if(!ans)
            ans++;
        if(n<0)
        {
            while(ans%2==0)
                ans/=2;
        }
        cout<<ans<<endl;
    }
}

  

posted @ 2017-11-14 17:17  会飞的雅蠛蝶  阅读(173)  评论(0编辑  收藏  举报