hdu 1754 I hate it

I Hate It

Time Limit : 9000/3000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 40   Accepted Submission(s) : 12
Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

 

Input
本题目包含多组测试,请处理到文件结束。 在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。 学生ID编号分别从1编到N。 第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。 接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。 当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。 当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 

 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 

 

Sample Input
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 

 

Sample Output
5 6 5 9 [hint]Huge input,the C function scanf() will work better than cin[/hint]
 
 
 
 
没啥好说的,基础题,就是敲的时候时候出了点小插曲。  scanf c[ ] 的时候,%s 写成了大写。
#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<queue>
using namespace std;
#define MAX 200005
#define ll long long
int tr[MAX*4];
void build(int n,int l,int r )
{
    if(l==r ){
        scanf("%d",&tr[n]);
        return ;
    }
    int mid =(l+r)/2;
    build(n*2,l,mid);
    build(n*2+1,mid+1,r);
    tr[n]=max(tr[n*2],tr[n*2+1]);
}
void up(int L,int R,int l,int r,int n)
{
    if(l==r){
        tr[n]=R;
        return ;
    }
    int m=(l+r)>>1;
    if(L<=m)
        up(L,R,l,m,n*2);
    else
        up(L,R,m+1,r,n<<1|1);
    tr[n]=max(tr[n*2],tr[n*2+1]);
}

int qu(int L,int R,int l,int r,int n )
{
    if(L<=l&&R>=r)
        return tr[n];

    int m =(l+r)>>1;
    int res=0;
    if(m>=L)
        res=max(res,qu(L,R,l,m,n*2));
    if(m<R)
        res=max(res,qu(L,R,m+1,r,n*2+1));
    return res;

}
int main()
{
    int n,m,T;
    while(~scanf("%d%d",&n,&m)){
      build(1,1,n);

      while(m--)
      {
          char c[2];
          scanf("%s",c);
          if(c[0]=='Q'){
                int a,b;
              scanf("%d%d",&a,&b);
              printf("%d\n",qu(a,b,1,n,1));
          }
          else if(c[0]=='U') {
              int a,b;
              scanf("%d%d",&a,&b);
              up(a,b,1,n,1);
          }


      }

  }
}

  更新后

#include<iostream>
#include<cstring>
#include<cstdio>
#include<ctime>
#include<algorithm>
#define N 200005
#define LL(x) (x<<1)
#define RR(x) (x<<1|1)
#define MID(a,b) (a+((b-a)>>1))
using namespace std;
struct node
{
    int l,r;
    int sum;
    int ma;
}tree[N*4];
int y[N];

void build(int l,int r,int n)
{
    tree[n].l=l;
    tree[n].r=r;
    tree[n].ma=0;
    if(l==r){
        tree[n].ma=y[l];
    }
    else{
        int m=(tree[n].l+tree[n].r)>>1;
        build(l,m,n<<1);
        build(m+1,r,n<<1|1);
        tree[n].ma=max(tree[n<<1].ma,tree[n<<1|1].ma);
        }
}

void updata(int in,int n,int v)
{

    if(tree[n].l==tree[n].r)
        tree[n].ma=v;
    else{
        int m=(tree[n].l+tree[n].r)>>1;
        if(in<=m)
            updata(in,n<<1,v);
        else
            updata(in,n<<1|1,v);
        tree[n].ma=max(tree[n<<1].ma,tree[n<<1|1].ma);
    }

}

int qu(int s,int e,int n)
{
    int res=0;
    if(tree[n].r<=e&&tree[n].l>=s)
        return tree[n].ma;
    else{
            int m=(tree[n].l+tree[n].r)>>1;
        int sum1=0,sum2=0;
        if(s<=m)
            res=max(res,qu(s,e,n<<1));
        if(e>m)
            res=max(res,qu(s,e,n<<1|1));

        return res;
    }
}

int main()
{
    int t;
    int m,n;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&y[i]);
        }
        build(1,n,1);
        while(m--)
        {
            char s[2];
            scanf("%s",s);
            int x,y;
            if(s[0]=='U'){
                scanf("%d%d",&x,&y);
                updata(x,1,y);
            }
            else{
                scanf("%d%d",&x,&y);
                printf("%d\n",qu(x,y,1));
            }
        }
    }

}

  

posted @ 2017-09-03 16:25  会飞的雅蠛蝶  阅读(106)  评论(0编辑  收藏  举报