hdu 4006 The kth great number

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65768/65768K (Java/Other)
Total Submission(s) : 51   Accepted Submission(s) : 20
Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.
 

 

Output
The output consists of one integer representing the largest number of islands that all lie on one line.
 

 

Sample Input
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

 

Sample Output
1 2 3 [hint]Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).[/hint]
 
 
利用优先队列和set容器很容易解出
 
 
#include<iostream>
#include<cmath>
#include<string>
#include<fstream>
#include<set>
using namespace std;
multiset <int> q;
multiset <int>::iterator it;
int main()
{
    int m,n;
    while(~scanf("%d%d",&n,&m))
    {
        q.clear();
        char s[2];
        while(n--)
        {
            int x;
            scanf("%s",&s);

            if(s[0]=='I'){
                scanf("%d",&x);
                q.insert(x);
                if(q.size()>m){
                    q.erase(q.begin());
                }
            }
            else{
                    it=q.begin();
                printf("%d\n",*it);
            }
        }
    }
}

  

posted @ 2017-08-29 10:49  会飞的雅蠛蝶  阅读(115)  评论(0编辑  收藏  举报