hdu 3584 三维树状数组

   

Problem Description
Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N). 
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].
 

 

Input
Multi-cases. First line contains N and M, M lines follow indicating the operation below. Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation. If X is 1, following x1, y1, z1, x2, y2, z2. If X is 0, following x, y, z.
 

 

Output
For each query output A[x, y, z] in one line. (1<=n<=100 sum of m <=10000)
 

 

Sample Input
2 5 1 1 1 1 1 1 1 0 1 1 1 1 1 1 1 2 2 2 0 1 1 1 0 2 2 2
 

 

Sample Output
1 0 1
 

 三维树状数组,单点修改。

想不明白画俩长方体就可以 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int sum[105][105][105];
int n;
int lowbit(int x)
{
    return x&(-x);
}
void updata(int x,int y,int z,int v  )
{
    for(int i =x;i<=n;i+=lowbit(i))
        for(int j=y;j<=n;j+=lowbit(j))
            for(int k=z;k<=n;k+=lowbit(k))
                sum[i][j][k]+=v;
}
int s(int x,int y,int z)
{
    int res=0;
    for(int i =x;i>0;i-=lowbit(i))
        for(int j=y;j>0;j-=lowbit(j))
            for(int k=z;k>0;k-=lowbit(k))
                res+=sum[i][j][k];
    return res;
}
int main()
{
    int m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(sum,0,sizeof(sum));
        while(m--)
        {
            int q,x,y,z,j,k,l;
            scanf("%d",&q);
            if(q==1){
                scanf("%d%d%d%d%d%d",&x,&y,&z,&j,&k,&l);
                updata(x,y,z,1);
                updata(x,y,l+1,1);
                updata(x,k+1,z,1);
                updata(x,k+1,l+1,1);
                updata(j+1,y,z,1);
                updata(j+1,y,l+1,1);
                updata(j+1,k+1,z,1);
                updata(j+1,k+1,l+1,1);
            }
            else {
                scanf("%d%d%d",&x,&y,&z);
                printf("%d\n",s(x,y,z)&1);
            }
        }
    }
}

  

posted @ 2017-08-28 21:49  会飞的雅蠛蝶  阅读(380)  评论(0编辑  收藏  举报