HDU 2846 Repository (字典树 后缀建树)


Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2932    Accepted Submission(s): 1116


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
0 20 11 11 2
 

Source
 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2846

题目大意:p个字符串,q个关键词,问有多少个字符串包括关键词

题目分析:对于每一个字符串,我们依照其后缀建立字典树,建树时须要加1个id。表示这个分支来自第几个字符串,不然会反复计数。比方例子的第三组查询


#include <cstdio>
#include <cstring>
char s[25];
int id;

struct node
{
    node *next[26];
    int cnt;
    int id;
    node()
    {
        memset(next, NULL, sizeof(next));
        cnt = 0;
        id = -1;
    }
};

void Insert(node *p, char *s, int index, int id)
{
    for(int i = index; s[i] != '\0'; i++)
    {
        int idx = s[i] - 'a';
        if(p -> next[idx] == NULL)
            p -> next[idx] = new node();
        p = p -> next[idx];
        if(p -> id != id)
        {
            p -> id = id;
            p -> cnt ++;
        }
    }
}

int Search(node *p, char *s)
{
    for(int i = 0; s[i] != '\0'; i++)
    {
        int idx = s[i] - 'a';
        if(p -> next[idx] == NULL)
            return 0;
        p = p -> next[idx];
    }
    return p -> cnt;
}

int main()
{
    int p, q;
    id = 0;
    node *root = new node();
    scanf("%d", &p);
    for(int i = 0; i < p; i++)
    {
        scanf("%s", s);
        int len = strlen(s);
        for(int j = 0; j < len; j++)
            Insert(root, s, j, i);
    }
    scanf("%d", &q);
    for(int i = 0; i < q; i++)
    {
        scanf("%s", s);
        printf("%d\n", Search(root, s));
    }
}


posted @ 2017-06-13 20:29  yfceshi  阅读(258)  评论(0编辑  收藏  举报