1146. Topological Order

题目:

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
6
5 2 3 6 4 1
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

 

Sample Output:

0 4 5

 

题目大意:给一个有向无环图(确定拓扑排序),判断给定序列是否是它的拓扑排序

 

思路:

用邻接表v存储这个有向图,并将每个节点的入度保存在in数组中。

对每一个要判断是否是拓扑序列的结点遍历,如果当前结点的入度不为0则表示不是拓扑序列(每次选中某个点后要将它所指向的所有结点的入度减去1),最后根据是否出现过入度不为0的点决定是否要输出当前的编号i

如下是判断一个给定的图是否是有向无环图

 

bool topologicalSort(){
  int num = 0;
  queue<int> q;
  for(int i = 0; i < n; i++){
    if(inDegree[i] == 0 ){
      q.push(i);
    }
  }
  while(!q.empty()){
    int u = q.front();
    q.pop()
    for(int i = 0; i < G[u].size(); i++){
      int v = G[u][i];
      inDegree[v] --;
      if(inDegree[v] == 0){
        q.push(v); 
      }
    }
    G[u].clear();
    num++;
  } 
  if(num == n) return true;
  else return false;

}

 

 

 

代码:(满分)

#include <iostream>
#include <vector>
using namespace std;
int main() {
    int n, m, a, b, k, flag = 0, in[1010];
    vector<int> v[1010];
    scanf("%d %d", &n, &m);
    for (int i = 0; i < m; i++) {
        scanf("%d %d", &a, &b);
        v[a].push_back(b);
        in[b]++;
    }
    scanf("%d", &k);
    for (int i = 0; i < k; i++) {
        int judge = 1;
        vector<int> tin(in, in+n+1);
        for (int j = 0; j < n; j++) {
            scanf("%d", &a);
            if (tin[a] != 0) judge = 0;
            for (int it : v[a]) tin[it]--;
        }
        if (judge == 1) continue;
        printf("%s%d", flag == 1 ? " ": "", i);
        flag = 1;
    }
    return 0;
}

 

posted @ 2023-05-31 16:42  Yohoc  阅读(3)  评论(0编辑  收藏  举报