1118 Birds in Forest(附测试点3分析)

题目:

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (104) which is the number of pictures. Then N lines follow, each describes a picture in the format:

B1 B2 ... BK

where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
 

Sample Output:

2 10
Yes
No
 
题目大意:一幅画里面的鸟为同一棵树上的,问有多少棵树和多少只鸟,以及对于两只鸟判断是否在同一个树上
 

易错:测试点3超时可能是因为在进行集合合并时没有进行路径压缩,具体的路径压缩代码如下:

把当前查询结点的路径上的所有结点的父亲都指向根节点

复制代码
int findFather(int x){
  int a = x;
  while(x != father[x]){
    x = father[x];
  } 
  while(a != father[a]){
    int z = a;
    a = father[a];
    father[z] = x;
  }
  return x;
}
复制代码

 

代码:(满分)

复制代码
#include<stdio.h>
#include<iostream>
using namespace std;
int father[10005], flag[10005]={0};
int findFather(int x){
  int a = x;
  while(x != father[x]){
    x = father[x];
  } 
  while(a != father[a]){
    int z = a;
    a = father[a];
    father[z] = x;
  }
  return x;
}
void Union(int x, int y){
    int faX = findFather(x);
    int faY = findFather(y);
    if(faX != faY){
        father[faY] = faX;
    }
}
int main(){
    int n, m, mx = -1;
    scanf("%d", &n);
    for(int i = 1; i <= 10000; i++){
        father[i] = i;
    }
    for(int i = 0; i < n; i++){
        int num, pre;
        scanf("%d", &num);
        for(int j = 0; j < num; j++){
            int index;
            scanf("%d", &index);
            if(index > mx) mx = index;
            if(j != 0) Union(pre, index);
            pre = index;
        }
    }
    int ans = 0;
    for(int i = 1; i <= mx; i++){
        if(father[i] == i){
            ans++;
        }
    }
    cout<<ans<<" "<<mx<<endl;
    scanf("%d", &m);
    for(int i = 0; i < m; i++){
        int x, y;
        scanf("%d%d", &x, &y);
        int faX = findFather(x);
        int faY = findFather(y);
        if(faX != faY){
            printf("No\n");
        }else{
            printf("Yes\n");
        }
    }
}
复制代码

 

posted @   Yohoc  阅读(19)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 使用C#创建一个MCP客户端
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 按钮权限的设计及实现
点击右上角即可分享
微信分享提示