1099 Build A Binary Search Tree

题目:

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N1, and 0 is always the root. If one child is missing, then 1will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
 

Sample Output:

58 25 82 11 38 67 45 73 42

 

题目大意:

给出一棵二叉搜索树(给出每个结点的左右孩子),且已知根结点为0,求并且给出应该插入这个二叉搜索树的数值,求这棵二叉树的层序遍历

 

思路:

将BST所有结点的值进行从小到大排序,就可以得到该BST的中序遍历。

已知树的结构,将这些结点的值按照中序遍历填入结点即可。具体代码如下:

int k = 0;
void inorder(int root){
    if(root >= n || root < 0)return;
    inorder(nodes[root].lchild);
    nodes[root].w = w[k++];
    inorder(nodes[root].rchild);
}

 

 

代码:

复制代码
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int n, k = 0;
int w[105];
bool flag = false;
struct Node{
    int w, lchild, rchild;
}nodes[105];
void inorder(int root){
    if(root >= n || root < 0)return;
    inorder(nodes[root].lchild);
    nodes[root].w = w[k++];
    inorder(nodes[root].rchild);
}
void levelOrder(int root){
    queue<int> q;
    q.push(root);
    while(!q.empty()){
        int tmp = q.front();
        q.pop();
        if(flag){
            printf(" ");
        }else{
            flag = true;
        }
        printf("%d", nodes[tmp].w);
        int left = nodes[tmp].lchild;
        int right = nodes[tmp].rchild;
        if(left != -1) q.push(left);
        if(right != -1)q.push(right);
    }
}
int main(){
    scanf("%d", &n);
    for(int i = 0; i < n; i++){
        int l,r;
        scanf("%d%d", &l, &r);
        nodes[i].lchild = l;
        nodes[i].rchild = r;
    }
    for(int i = 0; i < n; i++){
        scanf("%d", &w[i]);
    }
    sort(w,w+n); 
    inorder(0);
    levelOrder(0);
    return 0;
}
复制代码

 

posted @   Yohoc  阅读(12)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 使用C#创建一个MCP客户端
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 按钮权限的设计及实现
点击右上角即可分享
微信分享提示