1094 The Largest Generation

题目:

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]
 

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
 

Sample Output:

9 4

 

 

代码:(广度优先bfs)

复制代码
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
#include<unordered_map>
using namespace std;
int n, m, ans[105]={0};
struct Node{
    vector<int> children;
    int layer;
}node[105];
void bfs(int root){
    queue<int> q;
    q.push(root);
    node[root].layer = 1;
    ans[node[root].layer]++;
    while(!q.empty()){
        int tmp = q.front();
        q.pop();
        for(int k = 0; k < node[tmp].children.size(); k++){
            int c = node[tmp].children[k];
            node[c].layer = node[tmp].layer + 1;
            ans[node[c].layer]++;
            q.push(c);
        }
    }
}
int main(){
    scanf("%d%d", &n, &m);
    for(int i = 0; i < m; i++){
        int id, num;
        scanf("%d%d", &id, &num);
        for(int j = 0; j < num; j++){
            int child;
            scanf("%d", &child);
            node[id].children.push_back(child);
        }
    }
    bfs(1);
    int Max = -1, maxLayer = 0;
    for(int i = 1; i <= n; i++){
        if(ans[i] > Max){
            Max = ans[i];
            maxLayer = i;
        }
    }
    cout<<Max<<" "<<maxLayer;
    return 0;
}
复制代码

 

posted @   Yohoc  阅读(11)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 使用C#创建一个MCP客户端
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 按钮权限的设计及实现
点击右上角即可分享
微信分享提示