1076 Forwards on Weibo

题目:

 

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (1000), the number of users; and L (6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]
 

where M[i] (100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
 

Sample Output:

4
5

 

 

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
int n,l,m,k,nmax = 0;
vector<vector<int>> fans;
void bfs(int id){
    queue<int> que;
    que.push(id);
    vector<bool> visited(1005, false);
    vector<int> ranks(1005, 0);
    visited[id] = true;
    while(!que.empty()){
         int temp = que.front();
         que.pop();
         for(int i = 0; i < fans[temp].size(); i++){
             if(ranks[temp] >= l) break;
             if(!visited[fans[temp][i]]){
                 ranks[fans[temp][i]] = ranks[temp] + 1;
                 nmax++;
                 visited[fans[temp][i]] = true;
                 que.push(fans[temp][i]);
             }
         }
    }
}
int main(){
    scanf("%d %d", &n, &l);
    fans.resize(n + 1);
    for(int i = 1; i <= n; i++){
        scanf("%d", &m);
        for(int j = 0; j < m; j++){
            int temp;
            scanf("%d", &temp);
            fans[temp].push_back(i);
        }
    }
    scanf("%d", &k);
    for(int w = 0; w < k; w++){
        int id;
        scanf("%d", &id);
        bfs(id);
        printf("%d\n", nmax);
        nmax = 0;
    }
    return 0;
}

 

 

注意:

不要漏了 

1
fans.resize(n + 1);

否则会发生段错误

1
 
posted @   Yohoc  阅读(13)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 使用C#创建一个MCP客户端
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 按钮权限的设计及实现
点击右上角即可分享
微信分享提示