1011 World Cup Betting

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely Wfor win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1
 

To obtain the maximum profit, one must buy W for the 3rd game, Tfor the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
 

Sample Output:

T T W 39.31

 

 

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
#include<stdio.h>
#include<iostream>
using namespace std;
char r[] = {' ','W','T','L'};
double max(double a, double b, double c){
    double max = a;
    if(b > max){
        max = b;
    }
    if(c > max){
        max = c;
    }
    return max;
}
int find(double a, double b, double c, double m){
    if(m == a){
        return 1;
    }else if(m == b){
        return 2;
    }else{
        return 3;
    }
}
int main(){
    double w1,t1,l1;
    double w2,t2,l2;
    double w3,t3,l3;
    double p;
    cin>>w1>>t1>>l1;
    double m1 = max(w1, t1, l1);
    cin>>w2>>t2>>l2;
    double m2 = max(w2, t2, l2);
    cin>>w3>>t3>>l3;
    double m3 = max(w3, t3, l3);
    p = (m1 * m2 * m3 * 0.65 - 1) * 2;
    cout<<r[find(w1,t1,l1,m1)]<<" ";
    cout<<r[find(w2,t2,l2,m2)]<<" ";
    cout<<r[find(w3,t3,l3,m3)]<<" ";
    printf("%.2lf", p);
    return 0;
}

 

注意: 

switch-case 不支持double类型的变量

posted @   Yohoc  阅读(13)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 使用C#创建一个MCP客户端
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 按钮权限的设计及实现
点击右上角即可分享
微信分享提示