1056 Mice and Rice

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,,NP1) where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,,NP1 (assume that the programmers are numbered from 0 to NP1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

1
2
3
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

 

Sample Output:

1
5 5 5 2 5 5 5 3 1 3 5

 

思路 

首先可以简单证明,当前老鼠分为group组时,被淘汰的老鼠的排名是group+1。

这样不断淘汰直到剩下一只老鼠,比赛结束。题目增加了难度,老鼠不是依次比赛,而是按照题目给的序列,进行比赛。

我们使用一个队列来依次存放老鼠对应的下标。

 

核心代码:

 

复制代码
while((cnt = (int)q.size()) > 1){
        group = cnt / g + (cnt % g == 0 ? 0 : 1);
        for(int i = 0; i < group; i++){
            mx = -1;
            mxi = -1;
            for(int j = 0; j < g && i * g + j < cnt; j++){
                r[q.front()] = group + 1;
                if(w[q.front()] > mx){
                    mx = w[q.front()];
                    mxi = q.front();
                }
                q.pop();
            }
            q.push(mxi);
        }
    }
复制代码

 

 

 

 

代码

复制代码
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
int w[1005],r[1005];
int main(){
    int p,g,o;
    queue<int>q;
    cin>>p>>g;
    for(int i=0; i<p; i++){
        cin>>w[i];
    }
    for(int i=0; i<p; i++){
        cin>>o;
        q.push(o);
    }
    int group, cnt, mx, mxi;
    while((cnt = (int)q.size()) > 1){
        group = cnt / g + (cnt % g == 0 ? 0 : 1);
        for(int i = 0; i < group; i++){
            mx = -1;
            mxi = -1;
            for(int j = 0; j < g && i * g + j < cnt; j++){
                r[q.front()] = group + 1;
                if(w[q.front()] > mx){
                    mx = w[q.front()];
                    mxi = q.front();
                }
                q.pop();
            }
            q.push(mxi);
        }
    }
    r[q.front()] = 1;
    printf("%d", r[0]);
    for(int i = 1; i < p; i++){
        printf(" %d", r[i]);
    }
    return 0;
}
复制代码

 

posted @   Yohoc  阅读(16)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 使用C#创建一个MCP客户端
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 按钮权限的设计及实现
点击右上角即可分享
微信分享提示