1054 求平均值

题目:1054 求平均值

 

 

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。

 

输入格式:

 

输入第一行给出正整数 N(100)。随后一行给出 N 个实数,数字间以一个空格分隔。

 

输出格式:

 

对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y

 

输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

 

输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

 

输入样例 2:

2
aaa -9999

 

输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

 

思路:

1、巧妙运用sscanf 和 sprintf 来实现转换

2、测试点2错误: 当num=1时,输出为The average of 1 number is Y. 注意事number 不是 numbers

 

代码:

 

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<iomanip>
using namespace std;
int main(){
    int n,num = 0;
    char str[1005],sam[1005];
    double d,sum = 0;
    bool flag = true; 
    cin>>n; 
    for(int i=0; i<n; i++){
        cin>>str;
        sscanf(str, "%lf", &d);
        sprintf(sam, "%.2lf", d);
        flag = true;
        for(int i=0; i<strlen(str); i++){
            if(str[i] != sam[i]){
                flag = false;
            }
        }    
        if(flag == false || d > 1000 || d < -1000){
            cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
            continue;
        }
        num ++;
        sum += d; 
    }
    if(num == 0){
        cout<<"The average of 0 numbers is Undefined"<<endl;
    }else if(num == 1){
        cout<<"The average of 1 number is ";
        cout<<fixed<<setprecision(2)<<sum<<endl;
    }else{
        cout<<"The average of "<<num<<" numbers is ";
        cout<<fixed<<setprecision(2)<<sum / num<<endl;
    }
    return 0;
}

 

posted @ 2022-11-05 15:41  Yohoc  阅读(17)  评论(0编辑  收藏  举报