7-14 电话聊天狂人

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N(105),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

1
2
3
4
5
4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

 

输出样例:

1
13588625832 3

 

 

 

代码:

 

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include <iostream>
#include <string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include <vector>
#include <map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
#include<unordered_map>
#include<fstream>
using namespace std;
int main(){
    int n;
    cin>>n;
    map<string,int>mp;
    while(n--){
        string s1,s2;
        cin>>s1>>s2;
        mp[s1]++;
        mp[s2]++;
    }
    int t=0;
    string id;
    int count=0;
    for(auto it=mp.begin();it!=mp.end();it++){
        if(it->second>count){
            count=it->second;
            id=it->first;
        }
    }
    for(auto it=mp.begin();it!=mp.end();it++){
        if(it->second==count){
            t++;
        }
    }
    cout<<id<<" "<<count;
    if(t!=1) cout<<" "<<t;
    return 0;
}

 

 

 

 

 

 

总结:

map的注意点 

 

posted @   Yohoc  阅读(43)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 使用C#创建一个MCP客户端
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 按钮权限的设计及实现
点击右上角即可分享
微信分享提示