HDU 2844 Coins 多重背包

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6450    Accepted Submission(s): 2628


Problem Description
 
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

 

Input
 
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

 

Output
 
For each test case output the answer on a single line.

 

Sample Input
 
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
 
Sample Output
 
8
4
 
 
这是一道多重背包问题,题目的意思是有n中金币和m些钱,接下来给出n种金币的面值和数量,求出共能组合出多少种金额。初次学习,使用的是多重背包模板。
 
#include <iostream>
#include <cstdio>
using namespace std;
#define N 100003
int c[N],w[N];
int dp[N];
int n, v;
void ZeroOnePack(int cost,int weight)	//01背包
{
	for(int k=v; k>=cost; k--)
		dp[k] = max(dp[k],dp[k-cost]+weight);
}
void CompeletPack(int cost,int weight)	//完全背包
{
	for(int k=cost; k<=v; k++)
		dp[k] = max(dp[k],dp[k-cost]+weight);
}
void MultiplePack(int cost,int weight,int amount)	//多重背包
{
	if(cost*amount>=v)
	{
		CompeletPack(cost,weight);
		return;
	}
	else
	{
		int k=1;
		while(k<amount)
		{
			ZeroOnePack(k*cost,k*weight);
			amount = amount-k;
			k=k*2;
		}
		ZeroOnePack(amount*cost,amount*weight);
	}
}
int main()
{
	int i;
	while(scanf("%d %d",&n,&v) && n && v)
	{
		for(i=0; i<n; i++)
			scanf("%d",&c[i]);	//金币面值
		for(i=0; i<n; i++)
			scanf("%d",&w[i]);	//每种金币的个数
		memset(dp,0,sizeof(dp));
		for (i=0; i<n; i++)
		{
			MultiplePack(c[i],c[i],w[i]);
		}
		int sum=0;	//记录可以组成的金额数目
		for(i=1; i<=v; i++)
		{
			if(dp[i]==i)
				sum++;
		}
		printf("%d\n",sum);
	}
	return 0;
}

  

posted @ 2014-05-13 19:21  仰望天kong  阅读(139)  评论(0编辑  收藏  举报