424 - Integer Inquiry

 Integer Inquiry 

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

 

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

 

The final input line will contain a single zero on a line by itself.

 

Output

Your program should output the sum of the VeryLongIntegers given in the input.

 

Sample Input

 

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

 

Sample Output

 

370370367037037036703703703670
import java.util.*;
import java.io.*;
import java.math.*;
import java.text.*;
public class IntegerInquiry {
    public static void main(String[] args){
        Scanner sc = new Scanner(new BufferedInputStream(System.in));
        BigDecimal bd, ans;
        ans = new BigDecimal("0");
        while(sc.hasNext()){
            bd = new BigDecimal(sc.next());
            if(bd.equals(new BigDecimal("0")))
                break;
            ans = ans.add(bd);
        }
        System.out.println(ans);
    }
}
View Code

 

posted @ 2014-10-15 16:51  unicoe  阅读(164)  评论(0编辑  收藏  举报