Color the ball

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

Input每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。Output每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。Sample Input
3
1 1
2 2
3 3
3
1 1
1 2
1 3
0
Sample Output
1 1 1
3 2 1


看了一个大佬的方法,好聪明

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>

using namespace std;

int main()
{
    int n;
    int l,r;
    while(scanf("%d",&n)&&n!=0)
    {
        int a[100010]={0};
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&l,&r);
            a[l]++;
            a[r+1]--;
        }
        printf("%d",a[1]);
        for(int i=2;i<=n;i++)
        {
            a[i]+=a[i-1];
            printf(" %d",a[i]);
        }

        printf("\n");
    }
    return 0;
}

 

posted @ 2017-07-25 20:50  X_1996  阅读(175)  评论(0编辑  收藏  举报