Lake Counting

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
 
这题就是让你找有几个连通域,这题是向8个方向发散
 
#include<stdio.h>
#include<algorithm>
#include<iostream>

using namespace std;

char a[110][110];
int n,m;
int s=0;

void bfs(int i,int j)
{
    a[i][j]='.';
    if(j+1<m&&a[i][j+1]=='W')
        bfs(i,j+1);
    if(i+1<n&&a[i+1][j]=='W')
        bfs(i+1,j);
    if(i+1<n&&j+1<m&&a[i+1][j+1]=='W')
        bfs(i+1,j+1);
    if(i-1>=0&&j+1<m&&a[i-1][j+1]=='W')
        bfs(i-1,j+1);
    if(i-1>=0&&a[i-1][j]=='W')
        bfs(i-1,j);
    if(j-1>=0&&a[i][j-1]=='W')
        bfs(i,j-1);
    if(i-1>=0&&j-1>=0&&a[i-1][j-1]=='W')
        bfs(i-1,j-1);
    if(i+1<n&&j-1>=0&&a[i+1][j-1]=='W')
        bfs(i+1,j-1);
}

int main()
{
    scanf("%d%d",&n,&m);
    char c;
    scanf("%c",&c);
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
            scanf("%c",&a[i][j]);
        scanf("%c",&c);
    }
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            if(a[i][j]=='W')
            {
            //    printf("%d %d\n",i,j);
                s++;
                bfs(i,j);
            }
        }
    }
    printf("%d",s);
    return 0;
}

 

posted @ 2017-07-25 20:12  X_1996  阅读(131)  评论(0编辑  收藏  举报